uva 714 - Copying Books

Copying Books

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.


Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered $1, 2, \dots, m$) that may have different number of pages ( $p_1, p_2, \dots, p_m$) and you want to make one copy of each of them. Your task is to divide these books among k scribes, $k \le m$. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers $0 = b_0 <
b_1 < b_2, \dots < b_{k-1} \le b_k = m$ such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, $1 \le k \le m \le 500$. At the second line, there are integers $p_1, p_2, \dots p_m$ separated by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession $p_1, p_2, \dots p_m$ divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.


If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100
给定一组数,划分成k份,是每一份的和的最大值最小,当存在多种划分时,后面的和尽量大于前面的;
刚放完假做题奇慢Y Y,首先这个和一定是在这m个数中最大的到m个数
#include<stdio.h>
#include<string.h>
long long n,m,a[510],b[510],ans[510],left,right,mid,t;
long long check(long long  max)
{
 long long i,num=0,pos=0;
 memset(b,0,sizeof(b));
 for (i=n;i>=1;i--)
 {
  if (pos+a[i]<=max&&i>=m-num) pos=pos+a[i];
  else
  {
   ++num;
   pos=a[i];
   b[i]=1;
  }
 }

if (num+1==m)
 {
   for (i=1;i<=n;i++)
   ans[i]=b[i];
   return 1;
 }
 else return 0;
}
int main()
{
 long long i;
 scanf("%lld",&t);
 while (t--)
 {
  left=0; right=0;
  scanf("%lld%lld",&n,&m);
  for (i=1;i<=n;i++)
  {
   scanf("%lld",&a[i]);
   right+=a[i];
   if (a[i]>left) left=a[i];
  }
  memset(ans,0,sizeof(ans));
  while (left<=right)
  {
   mid=(left+right)/2;
   if (check(mid)==1) right=mid-1;
                 else left=mid+1;
  }
  for (i=1;i<n;i++)
  if (ans[i]==1) printf("%lld / ",a[i]);
        else printf("%lld ",a[i]);
  printf("%lld\n",a[n]);
 }
 return 0;
}


的和之间,所以可以二分查找,重点在判断某个值的划分是否成立,倒着贪心累加,注意k组划分不能有空集
 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值