hdu 1142 A Walk Through the Forest【Dijkstra+dfs求最短路条数】

67 篇文章 0 订阅
17 篇文章 0 订阅

链接:



A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4588    Accepted Submission(s): 1661


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
   
   
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
   
   
2 4
 

Source
 

Recommend
Eddy

算法:Dijkstra+dfs


思路:

开始题目都没有看懂,比赛完了后看了下飘过的小牛的题解:点击打开链接


题目大意:

给你一个图,找最短路的条数。
但是有个非一般的的条件:如果a,b之间有路,且你选择要走这条路,那么必须保证a到终点的所有路都小于b到终点的一条路。
问满足这样的路径条数 有多少。。。
PS:无向图。。。


解题思路:

1.1为起点,2为终点,因为要走ab路时,必须保证那个条件,所以从终点开始使用单源最短路Dijkstra算法,就得到了最短的一条路,
  作为找路的最低限度。
2.然后深搜每条路,看看满足题意的路径有多少条。当然,这个需要从起点开始搜,因为dis[i]数组中保存的都是该点到终点的最短距
  离。
3.这样搜索之后,path[1]就是从起点到终点所有满足题意的路径的条数。


自己就想不到想不到敲打
PS:好像应该去学下神奇的 spaf 了Orz

code:

/******************************************************************************************
开始题目都没有看懂,比赛完了后看了下飘过的小牛的题解

题目大意:
给你一个图,找最短路的条数。
但是有个非一般的的条件:如果a,b之间有路,且你选择要走这条路,那么必须保证a到终点的所有路都小于b到终点的一条路。
问满足这样的路径条数 有多少。。。
PS:无向图。。。

解题思路:
1.1为起点,2为终点,因为要走ab路时,必须保证那个条件,所以从终点开始使用单源最短路Dijkstra算法,就得到了最短的一条路,作为找路的最低限度。
2.然后深搜每条路,看看满足题意的路径有多少条。当然,这个需要从起点开始搜,因为dis[i]数组中保存的都是该点到终点的最短距离。
3.这样搜索之后,path[1]就是从起点到终点所有满足题意的路径的条数。

********************************************************************************************/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn = 1000+10;
const int INF = maxn*1000000;

int w[maxn][maxn]; //建图
int d[maxn]; //记录的是每个点到终点的最短路径长度
int vis[maxn];
int path[maxn]; //每个点到终点的最短路径的条数
int n,m;

void Dijkstra(int start)
{
    for(int i = 1; i <= n; i++) d[i] = w[start][i];
    d[start] = 0;

    memset(vis,0,sizeof(vis));
    for(int i = 1; i <= n; i++)
    {
        int x, m = INF;
        for(int y = 1; y <= n; y++) if(!vis[y] && d[y] <= m) m = d[x=y];
        vis[x] = 1;
        for(int y = 1; y <= n; y++)
            d[y] = min(d[y], d[x]+w[x][y]);
    }
}

int dfs(int u)
{
    if(path[u] != -1) return path[u]; //记忆化搜索
    if(u == 2) return 1; //如果到达了终点

    int sum = 0;
    for(int v = 1; v <= n; v++) //依次遍历每一个点
        if(w[u][v] != INF && d[v] < d[u]) //如果 u 到 v  有路, 而且 v 到终点的最短路径小于 u 到终点的最小路径
            sum += dfs(v);
    path[u] = sum;
    return path[u];
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        if(n == 0) break;

        scanf("%d", &m);
        for(int i = 1; i <= n; i++) //初始化
        {
            path[i] = -1;
            for(int j = 1; j <= n; j++)
            {
                w[i][j] = (i == j ? 0 : INF);
            }
        }

        int u,v,dist;
        while(m--)
        {
            scanf("%d%d%d", &u,&v,&dist);
            w[u][v] = min(w[u][v], dist); //避免重边的情况
            w[v][u] = w[u][v]; //无向图
        }

        Dijkstra(2); //从终点 2 开始找最短路
        printf("%d\n", dfs(1)); //起点 1 到终点 2 的最短路的条数
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
电子图书资源服务系统是一款基于 Java Swing 的 C-S 应用,旨在提供电子图书资源一站式服务,可从系统提供的图书资源中直接检索资源并进行下载。.zip优质项目,资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松copy复刻,拿到资料包后可轻松复现出一样的项目。 本人系统开发经验充足,有任何使用问题欢迎随时与我联系,我会及时为你解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(若有),项目具体内容可查看下方的资源详情。 【附带帮助】: 若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步。 【本人专注计算机领域】: 有任何使用问题欢迎随时与我联系,我会及时解答,第一时间为你提供帮助,CSDN博客端可私信,为你解惑,欢迎交流。 【适合场景】: 相关项目设计中,皆可应用在项目开发、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面中 可借鉴此优质项目实现复刻,也可以基于此项目进行扩展来开发出更多功能 【无积分此资源可联系获取】 # 注意 1. 本资源仅用于开源学习和技术交流。不可商用等,一切后果由使用者承担。 2. 部分字体以及插图等来自网络,若是侵权请联系删除。积分/付费仅作为资源整理辛苦费用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值