PAT 1007. Maximum Subsequence Sum (25)

1007. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. TheMaximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

分析: 这是道基本的动态规划题, 比较纠结的是题目没说清楚该如何对待0. 于是我还是选择了把0算在序列里面, 比如输入 3 0 1 2, 输出的是 3 0 2. 最后提交上去以后是正确的, 看样子的确是这样判定的


#include <iostream>
using namespace std;
int main(void)
{
	int K,i,sum=0,max=-1,temp,left=0;
	cin>>K;
	int lists[K],left_max,right_max;
	for(i = 0; i < K;i++)
		cin >> lists[i];
	left_max = right_max = left=lists[0];
	for(i = 0; i < K; i++)
	{
		sum += lists[i];
		if(sum > max)
		{
			left_max = left;
			right_max = lists[i];
			max = sum;
		}
		if(sum < 0 && i < K-1)
		{
			left = lists[i+1];
			sum = 0;
		}
	}
	if(max<0){
		max=0;
		left_max = lists[0];
		right_max = lists[K-1];
	}
	cout <<max<<" "<<left_max<<" "<<right_max;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值