PAT 1035. Password (20)

1035. Password (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified
Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified

字符串处理问题,代码如下:

#include <iostream>
#include <string>
#include <iomanip>
#include <set>
#include <vector>
#include <cstring>
using namespace std;
int main(void)
{
	int N;
	cin>>N;
	int i=N;
	vector<pair<string,string> > user;
	while(i--)
	{
		string userid,pwd;
		cin>>userid>>pwd;
		pair<string,string> temp;
		temp=make_pair(userid,pwd);
		user.push_back(temp);
	}
	vector<pair<string,string > >result;
	int size=user.size();
	for(i=0;i<size;i++)
	{
		string ori=user[i].second;
		string temp="";
		int flag=0;
		for(int j=0;j<ori.size();j++)
		{
			if(ori[j]=='1')
			{
				temp+="@";
				flag=1;
			}
			else if(ori[j]=='0')
			{
				temp+="%";
				flag=1;
			}
			else if(ori[j]=='l')
			{
				temp+="L";
				flag=1;	
			}	
			else if(ori[j]=='O')
			{
				temp+="o";
				flag=1;
			}
			else
				temp+=ori[j];
		}
		if(flag==1)
		{
			pair<string,string> t(user[i].first,temp);
			result.push_back(t);
		}
	}
	size=result.size();
	if(size==0)
	{
		if(N>1)
		{
			cout<<"There are "<<N<<" accounts and no account is modified"<<endl;
			return 0;
		}
		else if(N==1)
		{
			cout<<"There is 1 account and no account is modified"<<endl;
			return 0;
		}
	}
	cout<<size<<endl;
	for(i=0;i<size;i++)
		cout<<result[i].first<<" "<<result[i].second<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值