PAT 1078. Hashing (25)

1078. Hashing (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -

这道题考察Quadratic Probing,即H(key)=(key+i^2)%M, i<M,代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <iomanip>
#include <cstring>
using namespace std;
bool isprime(int x)
{
	if(x<2)
		return false;
	for(int i=2;i<=sqrt(x);i++)
		if(x%i==0)
			return false;
	return true;
}
int optimize(int x)
{
	int i;
	for(i=x;;i++)
		if(isprime(i))
			break;
	return i;
}

int main(void)
{
	int Msize,N;
	cin>>Msize>>N;
	int M=optimize(Msize);
	vector<int> table(M,0);
	int raw;
	cin>>raw;
	int pos=raw%M;
	table[pos]=1;
	printf("%d",pos);
	for(int i=1;i<N;i++)
	{
		cin>>raw;
		int j=1;
		pos=raw%M;
		while(j<M)
		{
			if(table[pos])
			{
				pos=(raw+j*j)%M;
				j++;
			}
			else
				break;
		}
		if(j<M)
		{
			cout<<" "<<pos;
			table[pos]=1;
		}
		else
			cout<<" -";
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值