PAT 1088. Rational Arithmetic (20)

1088. Rational Arithmetic (20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:
2/3 -4/2
Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
Sample Input 2:
5/3 0/6
Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

四则运算问题,仔细做就行了,代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <string>
#include <vector>
#include <map>
#include <cstring>
#include <climits>
using namespace std;
long int gcd(long int a,long int b)
{
	if(a<0)
		a=-a;
	if(b==0)
		return a;
	return gcd(b,a%b);
}
long int lcm(long int a,long int b)
{
	return a*b/gcd(a,b);
}
void print(long int num,long int den)
{
	bool ispositive=true;
	if(num==0)
	{
		cout<<"0";
		return;	
	}
	if(num<0)
	{
		ispositive=false;
		num=-num;
	}
	long int g=gcd(num,den);
	num/=g;
	den/=g;
	long int integer=0;
	if(num>=den)
	{
		integer=num/den;
		num%=den;
	}
	if(ispositive)
	{
		if(integer==0)
			cout<<num<<"/"<<den;
		else if(num!=0)
			cout<<integer<<" "<<num<<"/"<<den;
		else
			cout<<integer;
	}
	else
	{
		cout<<"(-";
		if(integer==0)
			cout<<num<<"/"<<den<<")";
		else if(num!=0)
			cout<<integer<<" "<<num<<"/"<<den<<")";
		else
			cout<<integer<<")";
	}
}
void add(long int anum,long int aden,long int bnum,long int bden,int flag)
{
	long int den=lcm(aden,bden);
	long int num=(anum*den/aden)+(bnum*den/bden);
	print(anum,aden);
	if(flag)
	{
		cout<<" + ";
		print(bnum,bden);	
	}
	else
	{
		cout<<" - ";
		print(-bnum,bden);
	}
	cout<<" = ";
	print(num,den);
	cout<<endl;
}
void mul(long int anum,long int aden,long int bnum,long int bden,int flag)
{
	long int num=anum*bnum;
	long int den=aden*bden;
	if(!flag&&den<0)
	{
		den=-den;
		num=-num;
	}
	print(anum,aden);
	if(flag)
	{
		cout<<" * ";
		print(bnum,bden);	
	}
	else
	{
		cout<<" / ";
		print(bden,bnum);
	}
	cout<<" = ";
	if(!flag&&den==0)
	{
		cout<<"Inf"<<endl;
		return;
	}
	print(num,den);
	cout<<endl;
}
int main(void)
{
	long int anum,aden,bnum,bden;
	scanf("%ld/%ld %ld/%ld",&anum,&aden,&bnum,&bden);
	long int g=gcd(anum,aden);
	anum/=g;
	aden/=g;
	g=gcd(bnum,bden);
	bnum/=g;
	bden/=g;
	add(anum,aden,bnum,bden,1);
	add(anum,aden,-bnum,bden,0);
	mul(anum,aden,bnum,bden,1);
	mul(anum,aden,bden,bnum,0);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值