HDU 1079 Calendar Game

题目传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1079


Problem Description
Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid. 

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game. 

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy. 

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001. 
 

Output
Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO". 
 

Sample Input
  
  
3 2001 11 3 2001 11 2 2001 10 3
 

Sample Output
  
  
YES NO NO

题意:博弈游戏。两个人操作一个日期,可以把日期往后移一个月或者往后移一天,把日期移到超过2001 年 11月 4 日的人就算输。


题解:

题目的意思就是谁把日期移到2001年11月4日就算赢。

感觉用SG应该可以过,但是会比较麻烦。

找规律的话,不管是往后移一个月还是往后移动一天,都会改变月份+日子的和(m+d)的奇偶性,而11月4日是奇数,所以如果一开始的日子是偶数则先手赢,否则后手赢。

————

恩,以为就这么简单。。然后就跪了。。

看了网上大牛的题解之后,发现其中9月30和11月30是特例,

思考一下:如果是先手必胜的局面,也就是说先手每次拿到的都是偶数的日子,那么先手一定不会选择去9月30日或者11月30日。如果是先手必败的局面,先手没有机会到达这两个特例。

所以,除非一开始的日期就是9月30或者11月30,否则其中不会出现这两个日期。


#include <stdio.h>
int main()
{
	int y,m,d;
	int t;
	scanf("%d",&t);
	while (t--)
	{
		scanf("%d%d%d",&y,&m,&d);
		if ((m+d)%2==0||(d==30&&(m==9||m==11))) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值