POJ 2773 Happy 2006

Happy 2006
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11832 Accepted: 4183

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5
 

题意是找与m互质的第k大的数。

首先枚举比m小的与m互质的个数,然后从前往后面找规律。举例 4:1是 2不是 3是 4不是。所以能够推出后面以4为

单位的数字里面也一定是这个关系 是 不是 是 不是。

这样通过求余就能够找到是第几个了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int prime[1000005];
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

int main()
{
    int m,k;
    while(scanf("%d%d",&m,&k)!=EOF)
    {
        int t=0;
        for(int i=1;i<=m;i++)
        {
            if(gcd(i,m)==1)
                prime[t++]=i;
        }
        if(k%t!=0)
            printf("%d\n",k/t*m+prime[k%t-1]);
        else printf("%d\n",(k/t-1)*m+prime[t-1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值