POJ-1730 Perfect Pth Powers 解题报告(数论) 最大开方数

连接--J -Perfect Pth Powers

Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u
 
Description
We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2

Hint

 

题目大意:输出一个数的最大开方数。(注意可能为负数)

#include <STDIO.H>
#include <MATH.H>

#define int64 __int64
#define I64d "%lld"

int64 POW(int b,int p){
    int i;
    int64 s=1;
    for(i=0;i< p;i++) s*=b;
    return s;
}

int main()
{
    int64 x,n;
    int i,y;
    
    while(scanf(I64d,&n),n){
        x=n>0?n:-n;
        for(i=32;i>=2;i--){
            y=(int)(pow((double)x,1.0/i)+0.5);
            if(POW(y,i)==x){
                if(n<0 && i%2==0) continue;
                else printf("%d\n",i);
                break;
            }
        }
        if(i==1) printf("1\n");
    }
    
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值