1027. Colors in Mars (20)

1027. Colors in Mars (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

这个题很简单,但是我能说我刚开始没理解题意吗?后来看了网上的解释,才知道这题其实就是进制转换和符合要求的格式输出,题目不难,代码也实现了,但是代码确实不优

//功能是实现了,代码确实不优美
int main()
{
	int r, g, b;
	int d = 13;
	cin >> r >> g >> b;
	vector<int> rnum;
	int rshang = r / d;
	int ryushu = r%d;
	rnum.push_back(ryushu);
	while (rshang != 0)
	{
		ryushu = rshang % d;
		rnum.push_back(ryushu);
		rshang = rshang / d;
	}	

	vector<int> gnum;
	int gshang = g / d;
	int gyushu = g%d;
	gnum.push_back(gyushu);
	while (gshang != 0)
	{
		gyushu = gshang % d;
		gnum.push_back(gyushu);
		gshang = gshang / d;
	}

	vector<int> bnum;
	int bshang = b / d;
	int byushu = b%d;
	bnum.push_back(byushu);
	while (bshang != 0)
	{
		byushu = bshang %  d;
		bnum.push_back(byushu);
		bshang = bshang / d;
	}

	cout << "#";
	if (rnum.size() == 1)
	{
		int num = rnum[0];
		cout << 0;
		if (num < 10)
		{
			cout << num;
		}
		else if (num==10)
		{
			cout << "A";
		}
		else if (num == 11){ cout << "B"; }
		else if (num == 12){ cout << "C"; }
	}
	else
	{
		for (int i = rnum.size() - 1; i >= 0; i--)
		{
			int num = rnum[i];
			if (num<10)
			{
				cout << num;
			}
			else if (num == 10){ cout << "A"; }
			else if (num == 11){ cout << "B"; }
			else if (num == 12){ cout << "C"; }
		}
	}

	
	if (gnum.size() == 1)
	{
		int num = gnum[0];
		cout << 0;
		if (num < 10)
		{
			cout << num;
		}
		else if (num == 10)
		{
			cout << "A";
		}
		else if (num == 11){ cout << "B"; }
		else if (num == 12){ cout << "C"; }
	}
	else
	{
		for (int i = gnum.size() - 1; i >= 0; i--)
		{
			int num = gnum[i];
			if (num<10)
			{
				cout << num;
			}
			else if (num == 10){ cout << "A"; }
			else if (num == 11){ cout << "B"; }
			else if (num == 12){ cout << "C"; }
		}
	}

	if (bnum.size() == 1)
	{
		int num = bnum[0];
		cout << 0;
		if (num < 10)
		{
			cout << num;
		}
		else if (num == 10)
		{
			cout << "A";
		}
		else if (num == 11){ cout << "B"; }
		else if (num == 12){ cout << "C"; }
	}
	else
	{
		for (int i = bnum.size() - 1; i >= 0; i--)
		{
			int num = bnum[i];
			if (num<10)
			{
				cout << num;
			}
			else if (num == 10){ cout << "A"; }
			else if (num == 11){ cout << "B"; }
			else if (num == 12){ cout << "C"; }
		}
	}
	return 0;
}

别人的简洁代码http://blog.csdn.net/realxuejin/article/details/10183487

#include<vector>
#include <sstream>
#include<cmath>
#include<iomanip>
#include<iostream>
#include <ctype.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;

char red[2];
char green[2];
char blue[2];

void change(int a, char color[2], int d)
{
	int i = 0;
	do
	{
		if ((a%d) < 10)
		{
			color[i++] = ((a%d) + '0');
		}
		else
		{
			color[i++] = (a%d) + 'A' - 10;
		}		
	} while (a != 0);
}

int main()
{
	memset(red, '0', sizeof(red));//用memset函数进行内存初始化
	memset(green,'0',sizeof(green));
	memset(blue,'0',sizeof(blue));

	int d = 13;
	int a, b, c;
	cin >> a >> b >> c;
	change(a, red, d);
	change(b, green, d);
	change(c, blue, d);
	cout << "#";
	cout << red[1] << red[0];
	cout << green[1] << green[0];
	cout << blue[1] << blue[0] << endl;

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值