关闭

FC5(Fedora Core5)下编译内核总结

2595人阅读 评论(1) 收藏 举报
摘要:
最近因工作需要,需要对linux内核进行重编译,发现了一些以前没有遇到过的 问题,些出来于 大家一起分享。

-------------------------------------
声明:
       此文为原创,欢迎转载,转载请保留如下信息
       作者:聂飞(afreez)北京。中关村
       联系方式:afreez@sina.com (欢迎与作者交流)
       初次发布时间:2006-06-08
      不经本人同意,不得用语商业或赢利性质目的,否则,作者有权追究相关责任!
-------------------------------------
测试环境及目标:
FC5(Fedora Core5)
对FC5(Fedora Core5) kernel及linux kernel 2.4.20即RedHat9进行编译,来测试framebuffer的一些功能。

序言
记得以前安装inux kernel 2.4.20即RedHat9完毕后,就可以在/usr/src目录里找到内核的源码,但是,最近才发现我的FC5(Fedora Core5)相应目录下竟然没有找到源码,可能是安装盘的问题或者是安装时忘记了什么选项,鬼才知道,反正是我 现在没有kernel的源码。

源码下载
从网上下载需要编译的内核,推荐如下连接
ftp://ftp.kernel.org/pub/linux/kernel
里面所有版本的 内核都有,尽情下把:)

编译过程
为了大家明白我的每一步骤,我把编译过程详细的描述如下:
开始我想对linux kernel 2.4.20内核先编译,因为毕竟linux kernel 2.4.20内核相对来说比较小,结果却引来来很多问题,具体如下
$ make rmproper
$make menuconfig
$make dep
上面这些步骤都能顺利通过
$make bzImage
一会就出现了如下的 错误

/usr/linux-2.4.20/include/linux/smp.h:29: error: conflicting types for 'smp_send_reschedule'
 /usr/linux-2.4.20/include/asm/smp.h:42: error: previous declaration of 'smp_send_reschedule' was here
In file included from /usr/linux-2.4.20/include/linux/unistd.h:9,
              from init/main.c:17:
/usr/linux-2.4.20/include/asm/unistd.h:375: warning: conflicting types for built-in function '_exit'
make: *** [init/main.o] Error 1

到网上查了查,发现是FC5下的GCC版本太新(gcc4.1),无法编译
linux-2.4.20?????????
在一个国外网站上也发现了类似的 问题,他们的建议是使用 gcc 2.95或者gcc3.2进行编译(Dave Thompson),心想难道要要把gcc的 版本降下去不成?
在网上寻找了一会,发现其实FC5下可以安装一个pachage,就可以使用
gcc3.2,同时不会影响当前的gcc4.1。于是就在ftp://rpmfind.net/linux/fedora/core/5/i386/os/Fedora/RPMS/compat-gcc-32-3.2.3-55.fc5.i386.rpm里下载了一个,该包的大致描述为:The compatibility GNU Compiler Collection   Fedora Core 5 for i386,马上进行安装
$rpm -ivh
compat-gcc-32-3.2.3-55.fc5.i386.rpm
Preparing...                ########################################### [100%]
package compat-gcc-32-3.2.3-55.fc5 is already installed

看到了把,FC5竟然默认已经安装上该包了~~~~~~~~~~
于是马上修改Makefile,把里面的CC修改为 GCC3.2

$make mrprop*;make clean
$make dep
$make bzImage

经过漫长的等待(不长,也就15分钟左右),结果等来的却是:

 {standard input}: Assembler messages:
{standard input}:936: Error: suffix or operands invalid for `mov'
 {standard input}:937: Error: suffix or operands invalid for `mov'
{standard input}:1031: Error: suffix or operands invalid for `mov'
{standard input}:1032: Error: suffix or operands invalid for `mov'
 {standard input}:1083: Error: suffix or operands invalid for `mov'
 {standard input}:1084: Error: suffix or operands invalid for `mov'
{standard input}:1086: Error: suffix or operands invalid for `mov'
 {standard input}:1098: Error: suffix or operands invalid for `mov'

没办法 ,把 错误信息输入到google里面,发现很多人都遇到过类似的麻烦。最后的 结论:是FC5下的binutils的一个bug,于是了相应的补丁http://www.kernel.org/pub/linux/devel/binutils/linux-2.6-seg-5.patch,在待编译的内核源码(本例为
linux-2.4.20/)的根目录下进行patch操作:
$patch -p0 <
linux-2.6-seg-5.patch
或者
$patch -p1 <linux-2.6-seg-5.patch
详细请查阅patch的用法。
/*
patch的用法简介
格式
patch -pnumber <patch_file
参数p的含义
容易变化的部分是‘-p’参数后面的‘number’,定义了补丁应用于何种扩展方式的路径:
 ‘-p0’是应用补丁文件中给出的全路径,‘-p1’则删掉第一个斜杠(slash:/),依此类推。
没有指定的‘-p’将除去全部路径,如果这个补丁只是应用于同一个目录下的文件,这样做就很好。
  通常的做法是,将补丁文件放在源代码的上一级目录,然后运行
 patch -p1 <patch_file
*/

patch完之后,再一次重新编译,当
$make bzImage
后,一切正常
$make modules
$make modules_install
后,竟然还出现了如下的信息

cd /lib/modules/2.4.20; /
mkdir -p pcmcia; /
find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia
if [ -r System.map ]; then /sbin/depmod -ae -F System.map  2.4.20; fi
Version requires old depmod, but couldn't run /sbin/depmod.old: No such file or directory

做了如下措施
$ln -s /sbin/depmod /sbin/depmod.old
$make modules_install
$mkinitrd -f -v /boot/initrd-2.4.20.img 2.4.20
一切正常

修改相应的lino或者 grub,重新启动。

在编译时,发现如果编译FC5 kernel,它的
grub会自动被修改,不需要手动修改。

编译
C5 kernel和kernel 2.4.20,他们的编译过程可能有点稍微不同,具体的步骤见各根目录下的READERME文件,里面说的很详细。



0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:225776次
    • 积分:2926
    • 等级:
    • 排名:第12463名
    • 原创:57篇
    • 转载:25篇
    • 译文:2篇
    • 评论:41条
    最新评论