关闭

Can’t install ia32-libs and ia32-libs-multiarch: how to fix it

393人阅读 评论(0) 收藏 举报
分类:

http://rumytaulu.com/2012/10/26/cant-install-ia32-libs-and-ia32-libs-multiarch-how-to-fix-it/


When tried to install teamviewer on my Ubuntu 12.04 64bit, the system complaining about unmet dependencies and can not install ia32-libs, but when I tried to install ia32-libs, here’s what I got:

rumy@cbug-nest:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
E: Unable to correct problems, you have held broken packages.

An attemp to install ia32-libs-multiarch failed too

After some dig on internet I found the solution:

(1) Edit /etc/apt/preferences

rumy@cbug-nest~$ sudo pico /etc/apt/preferences

(2) Add this 3 line code

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

(3) Do dist-upgrade

rumy@cbug-nest~$ sudo apt-get dist-upgrade

It will ask you to downgrade some package, just answer (Y)es

(4) Install ia32-libs-multiarch and/or ia32-libs

rumy@cbug-nest~$ sudo apt-get install ia32-libs-multiarch


(5) Delete /etc/apt/preferences, after you finished updating

rumy@cbug-nest~$ rm /etc/apt/preferences



0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:341278次
    • 积分:4972
    • 等级:
    • 排名:第5689名
    • 原创:115篇
    • 转载:243篇
    • 译文:0篇
    • 评论:41条
    最新评论