二叉排序树 遍历 ACM 试题 C语言实现



//
//题目描述:
//	输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。
//	输入:
//	输入第一行包括一个整数n(1<=n<=100)。
//	接下来的一行包括n个整数。
//	输出:
//	可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。
//	每种遍历结果输出一行。每行最后一个数据之后有一个空格。
//	样例输入:
//	5
//	1 6 5 9 8
//	样例输出:
//	1 6 5 9 8 
//	1 5 6 8 9 
//	5 8 9 6 1 
#include <stdio.h>
#include <stdlib.h>

typedef struct Tree{
	struct Tree *l;
	struct Tree *r;
	int data;
}Tree,*pTree;

void add(pTree boot,pTree tree){
	if(boot->data == tree->data)
		return;
	else if(boot->data > tree->data){
		if(boot->l != NULL)
			add(boot->l,tree);
		else
			boot->l = tree;
	}else{
		if(boot->r != NULL)
			add(boot->r,tree);
		else
			boot->r = tree;
	}
}

void pre_see(pTree tree){
	if( tree == NULL)
		return;
	printf("%d ",tree->data);
	pre_see(tree->l);
	pre_see(tree->r);
}

void mid_see(pTree tree){
	if(tree == NULL)
		return;	
	mid_see(tree->l);
	printf("%d ",tree->data);
	mid_see(tree->r);
}

 void last_see(pTree tree){
	if(tree == NULL)
		return;
	last_see(tree->l);
	last_see(tree->r);
	printf("%d ",tree->data);
}

int main()
{
	int n;
	while(scanf("%d",&n) != EOF){
		int i;
		pTree  boot  ;
		for(i=0; i<n; i++){
			if( i==0){
				boot = (pTree)malloc(sizeof(Tree));
				scanf("%d",&boot->data);
				boot->l = NULL;
				boot->r = NULL;
			}
			else{
				pTree temp;
				temp = (pTree)malloc(sizeof(Tree));
				scanf("%d",&temp->data);
				temp->l = NULL;
				temp->r = NULL;			
				add(boot,temp);
			}

		}

		pre_see(boot);printf("\n");
		mid_see(boot);printf("\n");
		last_see(boot);printf("\n");

	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值