【第22期】观点:IT 行业加班,到底有没有价值?

Maven创建所遇到的问题记录

原创 2016年05月31日 22:36:01

Maven创建所遇到的问题记录:

第一次搭建ssm框架,eclipse搭建maven时候,遇到了各种奇葩奇怪的问题,各种百度Google,终无解。

偶然看见的maven官网maven对jdk版本的要求,记录下来,希望大家少像我一样走弯路。

不正确的地方也请大家指正!

也希望有没有提到的错误请大家留言。


1. maven下src--main--webapp--index.jsp报红叉

报错:The superclass "javax.servlet.http.HttpServlet" was not found on the Java Build Path

原因:pom.xml未引入java

解决方案:   <dependency>  
            <groupId>javax</groupId>  
            <artifactId>javaee-api</artifactId>  
            <version>7.0</version>  
             </dependency> 

2. maven项目下pom.xml下packaging报错

错误代码记不清楚了
Execution default-testResources of goal org.apache.maven.plugins:maven-resources- plugin:2.5:testResources failed: A required class was missing while executing org.apache.maven.plugins:maven-resources-plugin:2.5:testResources: org/codehaus/plexus/util/StringUtils 
这个是对应的文件没有下载到本地造成的,建议删除下载对应xml中,重新下载。

3. maven项目下java resources报红叉

Description Resource Path Location Type
JavaServer Faces 2.2 can not be installed : One or more constraints have not been satisfied. storm line 1 Maven Java EE Configuration Problem
JavaServer Faces 2.2 requires Dynamic Web Module 2.5 or newer. storm line 1 Maven Java EE Configuration Problem
Description Resource Path Location Type
JAX-RS (REST Web Services) 2.0 can not be installed : One or more constraints have not been satisfied. storm line 1 Maven Java EE Configuration Problem
Description Resource Path Location Type
JAX-RS (REST Web Services) 2.0 requires Java 1.6 or newer. storm line 1 Maven Java EE Configuration Problem
原因:个人认为是版本对应问题,博主用的jdk1.7,使用maven3.2.1时报错。查了好久,不管是update project还是
手动更改Dynamic Web Module 都没有作用,最后查官网对于版本对应要求如下图:

换成最新版maven3.3.9对应jdk1.7;不再报这四个错误。

4. maven项目下java resources报感叹号

原因:版本对应问题
解决方案:解决方案:项目右击propreties--java build path -libraries - JRE System Library - EDIT - 选择 workplace default jre

5. 警告信息

Description Resource Path Location Type
Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace tha t are strictly compatible with this environment. storm Build path JRE System Library P roblem

解决方案:项目右击propreties--Project Facets--Java中version选对应的版本信息;


各位有其他错误信息可留言探讨,problems 下打印出的信息


(window -- show view - others - 搜索 problems )

转载请声明出处!

版权声明:本文为博主原创文章,未经博主允许不得转载。 举报

相关文章推荐

maven常见错误

常见错误: 一..在Eclipse导入已存在工作空间的项目,出现 情况1: Scanning errors (1): 1 Could not read pom.xml 就是p...

JavaServer Faces 2.2 can not be installed

JavaServer Faces 2.2 can not be installed : One or more constraints have not been satisfied. JavaSe...

maven整理

安装与配置windows版maven(前提:先安装jdk): 1.到http://maven.apache.org下载最新maven3.1.1并解压到D盘,并将解压目录改名为maven3 2.修改D:...

JavaServer Faces 2.2 requires Dynamic Web Module 2.5 or newer

JavaServer Faces 2.2 can not be installed : One or more constraints have not been satisfied JavaSer...

Maven项目,右键-update project后报错

Maven项目,右键-update project后报错如下的解决办法: 1、Description Resource Path Location Type Java compiler level d...

maven+springmvc错误 JAX-RS (REST Web Services) 2.0 can not be installed

项目problem提示错误 JAX-RS (REST Web Services) 2.0 can not be installed : One or more constraints have no...

spring-websocket框架搭建遇到的问题解决方案汇总

问题1 org.apache.tomcat.websocket.server.WsServerContainer cannot be cast to javax.websocket.server 严...

Eclipse Java EE工程报错:JAX-RS (REST Web Services) 2.0 can not be installed、JAX-RS (REST Web Services) 2

导入了一个Java EE SDK7 里面的工程,Eclipse报错JAX-RS (REST Web Services) 2.0 can not be installed : One or more c...

JAX-RS (REST Web Services) 2.0 requires Java 1.6 or newer.

maven 项目出现JAX-RS (REST Web Services) 2.0 requires Java 1.6 or newer.错误 解决办法:       这个是eclipse的...

JAX-RS(REST Web Services)2.0 requires Dynamic Web Module 3.1 or newer

eclipse错误
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)