hdu 5875 2016 ACM/ICPC Asia Regional Dalian Online 1008


Function

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1427    Accepted Submission(s): 126


Problem Description
The shorter, the simpler. With this problem, you should be convinced of this truth.
  
  You are given an array A of N postive integers, and M queries in the form (l,r) . A function F(l,r) (1lrN) is defined as:
F(l,r)={AlF(l,r1) modArl=r;l<r.
You job is to calculate F(l,r) , for each query (l,r) .
 

Input
There are multiple test cases.
  
  The first line of input contains a integer T , indicating number of test cases, and T test cases follow.
  
  For each test case, the first line contains an integer N(1N100000) .
  The second line contains N space-separated positive integers: A1,,AN (0Ai109) .
  The third line contains an integer M denoting the number of queries.
  The following M lines each contain two integers l,r (1lrN) , representing a query.
 

Output
For each query (l,r) , output F(l,r) on one line.
 

Sample Input
  
  
1 3 2 3 3 1 1 3
 

Sample Output
  
  
2
 



题意:

给出m个区间 (L,R),求出从L处的数左往右取模至R的答案;



思路:

用优先队列求出一个数向右的第一个比他小的值,在求答案的时候就可以直接跳转到比他小的值。

因为在和它取模之后,再和比它大的值取模是没有意义的。


代码:


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int maxn =100005;
int data[maxn];
int flag[maxn];

priority_queue<int >q;

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        int i,j;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            scanf("%d",&data[i]);


        q.push(1);
        for(i=2;i<=n;i++){
            while(!q.empty()&&data[i]<data[q.top()]){
                flag[q.top()]=i;
                q.pop();
            }
            q.push(i);
        }
        while(!q.empty()){
            flag[q.top()]=-1;
            q.pop();
        }

        int m;
        scanf("%d",&m);
        for(i=1;i<=m;i++){
            int l,r;
            scanf("%d%d",&l,&r);
            int fn=l;
            int ans=data[l];
            while(fn<=r){
                int wtf=flag[fn];
                if(wtf==-1)
                    break;
                else if(wtf>r)
                    break;
                else if(wtf<=r){
                    ans=ans%data[wtf];
                    fn=wtf;
                }
                if(ans==1)
                    break;
            }
             printf("%d\n",ans);
            }

        }
        return 0;
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值