POJ 1743 Musical Theme 后缀数组 二分

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 
Input
The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 
Output
For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.
Sample Input
30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0
Sample Output
5
Hint
Use scanf instead of cin to reduce the read time.


差不多可以说是一个后缀数组的板题了。

好吧,用我自己的那个归并排序的写法会TLE,但是道理上是一样的。。

因为这个题目要求的是找到一个最长的不重叠子串,二分一个长度len,判定height数组里面是不是有一组后缀的height大于等于len且最大位置大于等于最小位置+len

交了许多次才AC。。。慢慢地就会变好的。。

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>

const int maxm=20010;

int n,wa[maxm],ws[maxm],wv[maxm],arr[maxm],wb[maxm],raw[maxm],sa[maxm],*x,*y,height[maxm],_rank[maxm],ans;

void da(),calheight();
inline bool cmp(int* r,int a,int b,int L){return r[a]==r[b]&&r[a+L]==r[b+L];};
inline bool cmp1(int a,int b){return x[a]<x[b];}
bool judge(int len);
template <typename T>T max(const T& a,const T& b,const T& c){return std::max(a,std::max(b,c));}
template <typename T>T min(const T& a,const T& b,const T& c){return std::min(a,std::min(b,c));}

int main(){
    using namespace std;
    ios_base::sync_with_stdio(0);
    while(cin>>n&&n){
        if(n<10){
            for(int i=0;i<n;++i)
                cin>>arr[0];
            cout<<0<<endl;
            continue;
        }
        cin>>arr[0];
        for(int i=1;i<n;++i){
            cin>>arr[i];
            raw[i-1]=arr[i-1]-arr[i]+100;
        }

        da();
        calheight();

        int ri=n,le=1;
        while(ri>le+1)(judge((le+ri)>>1)?le:ri)=((le+ri)>>1);
        ans=(le==ri||judge(ri)?ri:le);
        cout<<(ans>=4?ans+1:0)<<endl;
    }
    return 0;
}

void da(){
    int m=200,i,j,p;
    x=wa,y=wb;

    memset(ws,0,sizeof ws);
    for(i=0;i<n;++i)ws[x[i]=raw[i]]++;
    for(i=1;i<m;++i)ws[i]+=ws[i-1];
    for(i=n-1;i>=0;--i)sa[--ws[x[i]]]=i;
    for(j=1,p=1;p<n;j<<=1,m=p){

        for(p=0,i=n-j;i<n;++i)y[p++]=i;
        for(i=0;i<n;++i)if(sa[i]>=j)y[p++]=sa[i]-j;
        for(i=0;i<n;++i)wv[i]=x[y[i]];
        memset(ws,0,sizeof ws);
        for(i=0;i<n;++i)ws[wv[i]]++;
        for(i=1;i<m;++i)ws[i]+=ws[i-1];
        for(i=n-1;i>=0;--i)sa[--ws[wv[i]]]=y[i];
        for(std::swap(x,y),p=1,x[sa[0]]=0,i=1;i<n;++i)
        x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}


void calheight(){
    for(int i=1;i<n;++i)_rank[sa[i]]=i;
    for(int i=0,j,k=0;i<n;height[_rank[i++]]=k)
    for(k?k--:0,j=sa[_rank[i]-1];raw[i+k]==raw[j+k];++k);
}

bool judge(int len){
    int le=0x3f3f3f3f,ri=-0x3f3f3f3f;
    for(int i=1;i<n;++i)
    if(height[i]>=len)
        le=min(le,sa[i],sa[i-1]),ri=max(ri,sa[i],sa[i-1]);
    else{
        if(ri>=le+len)
            return true;
        ri=-(le=0x3f3f3f3f);
    }
    return ri>=le+len;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值