关闭

netCDF4-python的安装

标签: netcdf4 python
2118人阅读 评论(0) 收藏 举报
分类:

这个库我安的要死要活的,尤其是提示hd5f相关的错误,还有h5py库。

直接pip,easy_install 都失败了,直接下sourcecode编译也都是问题(编不过,编过了导入失败)


Windows:

直接去 http://www.lfd.uci.edu/~gohlke/pythonlibs/#jpype  下载对应的whl文件,使用

pip install x.whl

安装即可,可能需要安其他的库,都可以在这个链接中找到


CentOS(7):

出离愤怒啊,搞了一大堆编译的东西都解决不了 - -!

要先安装epel这个yum源,netCDF4和相关的在这个源中可以获得

yum -y install epel-release
检测是否安装成功可以通过下面的命令检查,如果有版本信息的打印说明安装成功

rpm -q epel-release
接下来就可以安装netCDF4-python和相关的库了

yum install netcdf4-python


Ubuntu :

可以安完的,在stackoverflow上可以找到一些,试的试的就可以了,两次各花半天,下次遇到再上图

有 apt-get install python-netcdf4

sudo ldconfig on all relevant
sudo apt-get install libhdf5-serial-dev
sudo apt-get install libnetcdf-dev
sudo apt-get install libnetcdf4
sudo apt-get install python-netcdf
</pre><pre code_snippet_id="1705134" snippet_file_name="blog_20160602_7_674880" name="code" class="plain">
祝大家:
>>> import netCDF4
>>>









0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:26094次
    • 积分:437
    • 等级:
    • 排名:千里之外
    • 原创:18篇
    • 转载:2篇
    • 译文:0篇
    • 评论:4条
    文章分类
    最新评论