hdu1299.Diophantus of Alexandria

6 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1299

Diophantus of Alexandria



Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.
Consider the following diophantine equation: 
1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)


Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions: 
1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4



Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?
 
Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9). 
 
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line. 
 
Sample Input
2
4
1260
 
Sample Output
Scenario #1:
3
Scenario #2:
113


题意,给一给n,问有多少正整数对(x, y)满足1/x + 1/y = 1/n, (x,y)跟(y,x)是一样的。

大致思路:设x=pk,y=qk (gcd(p,q) = 1)  那么1/x+1/y = 1/pk+1/qk = (p+q)/pqk = 1/n ==> n = pqk/(p+q)...因为p,q互质且n为整数。所以n=p*q*(k/(p+q)).

pq固定下来,k也固定了。然后分解质因式n=p1^r1*p2^r2*...*pt^rt..。枚举每个因子属于p还是q还是都不属于,同时枚举次数。最后相加起来就是答案。

代码:

#include <map>
#include <cmath>
#include <queue>
#include <string>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define MAXN 40000
#define eps (1e-9)
#define INF 1000000000
#define abs(x) ((x) > 0? (x): -(x))
#define sqr(x) ((x) * (x))
#define two(x) (1 << (x))

typedef long long LL;

int n, tp, tf, ans, pr[MAXN], tn[20];
bool isp[MAXN];

void make_primes()
{
    tp = 0;
    memset(isp, 1, sizeof(isp));
    for (int i = 2; i < MAXN; ++i)
    {
        if (isp[i]) pr[++tp] = i;
        for (int j = 1; j <= tp && pr[j] * i < MAXN; ++j)
        {
            isp[pr[j] * i] = false;
            if (i % pr[j] == 0) break;
        }
    }
}

void init()
{
    scanf("%d", &n);
    tf = 0;
    int x = n;
    for (int i = 1; i <= tp && sqr(pr[i]) <= x; ++i) if (x % pr[i] == 0)
    {
        tn[++tf] = 0;
        while (x % pr[i] == 0)
        {
            ++tn[tf];
            x /= pr[i];
        }
    }
    if (x > 1)
        tn[++tf] = 1;
    ans = 0;
}

void dg(int x, int p, int q, bool hasp)
{
    if (x == tf + 1)
        ans += p * q;
    else
    {
        dg(x + 1, p, q, hasp);
        dg(x + 1, p * tn[x], q, true);
        if (hasp) dg(x + 1, p, q * tn[x], hasp);
    }
}

int main()
{
    make_primes();
    int T, ca = 0;
    scanf("%d", &T);
    while (T--)
    {
        printf("Scenario #%d:\n", ++ca);
        init();
        dg(1, 1, 1, false);
        printf("%d\n\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值