简单数学训练-B

Description

Given a positive integer N, you should output the most right digit of N^N. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

Output

For each test case, you should output the rightmost digit of N^N. 
 

Sample Input

     
     
2 3 4
 

Sample Output

     
     
7 6

Hint

 In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6. 

通常循环超时, 本题利用尾数循环规律。

#include <stdio.h>
int main()
{
    int T;
    scanf("%d", &T);
    while (T--){
        int n, num, op ;
        scanf("%d", &n);
        num = n % 10;
        int flag[10] ={1,1,4,4,2,1,1,4,4,2};
        int i, p;
        if (n >= flag[num] && (n % flag[num]) )
            p = n % flag[num];
        else if  (n >= flag[num] && !(n % flag[num]))
            p = flag[num];
        else p = n;
//        printf("p = %d\n", p);
        op = 1;
        for ( i = 1; i <=  p; i++){
            if (op > 10){
                op = op % 10;
                op *= num;
            }
            else op *= num;
        }
        op = op % 10;
        printf("%d\n", op);
        }
}


快速幂带取余做法
#include <stdio.h>
int fastpow(int x, int n,int mods) //快速幂带取余,非递归--不调用自身
{
    int sum = 1;
    while (n > 0) {
        if (n & 1){      // n & 1 等价于 (n % 2) == 1
            x = x % mods;
            sum *= x;
            sum = sum % mods;
            n-- ;
        }
        else {
            x = x % mods;
            x *= x;
            x = x % mods;
            n /= 2;        // n >>= 1 等价于 n /= 2
        }
    }
    sum = sum % mods;
    return sum;
}

int main()
{
    int n,a,b,ends;
    scanf("%d", &n);
    while (n--){
        scanf("%d", &a);
        b = a;
        ends = fastpow(a,b,10);
        printf("%d\n", ends);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值