HPUOJ---2017寒假作业--专题-1/J-Key Set

J - Key Set

 

soda has a set  S S with  n n integers  {1,2,,n} {1,2,…,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S S are key set.
Input
There are multiple test cases. The first line of input contains an integer  T T  (1T105) (1≤T≤105), indicating the number of test cases. For each test case: 

The first line contains an integer  n n  (1n109) (1≤n≤109), the number of integers in the set.
Output
For each test case, output the number of key sets modulo 1000000007.
Sample Input
4
1
2
3
4
Sample Output
0
1
3
7
 
   
思路:(1):集合各子集中,各数字之和为偶数的非空子集个数为2的n-1次方-1;那么,和为奇数的非空子集
             个数为2的n-1次方。
      (2):最后要对一个数求余,用到同余定理,(a+b)%C=(a%c+b%c)%c。
      (3):2的n-1次方对一个数取余,用到快速幂。
#include<cstdio>
#define mod 1000000007
typedef long long LL;
LL Quick_MI(LL a,LL b,LL c)
{
	int s=1;
	while(b)
	{
		a=a%c;
		if(b&1)                  //按位与运算,二进制形式,判断b的奇偶
		{
			s=(s*a)%c;
		}
		a=(a*a)%c;
		b=b/2;
	}
	return s;                     //快速幂
}
int main()
{
	int T;
	long long p,m,n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lld",&n);
		p=Quick_MI(2,n-1,mod);
		m=(p-1)%mod;          //同余定理
		printf("%lld\n",m);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值