POJ1014——Dividing

175 篇文章 0 订阅
16 篇文章 2 订阅
Dividing
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 60332 Accepted: 15567

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source

Mid-Central European Regional Contest 1999

多重背包水题


#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <vector>  
#include <queue>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  

using namespace std;


int dp[720010];
int w[8];
int num[8];
int v;

void zero_one(int weight)
{
	for (int i = v; i >= weight; i--)
	{
		dp[i] = max(dp[i], dp[i - weight] + weight);
	}
}

void wanquan(int weight)
{
	for (int i = weight; i <= v; i++)
	{
		dp[i] = max(dp[i], dp[i - weight] + weight);
	}
}

void duochon(int amount, int weight)
{
	if (amount * weight >= v)
	{
		wanquan(weight);
		return;
	}
	int k = 1;
	while(k < amount)
	{
		zero_one(k * weight);
		amount -= k;
		k <<= 1;
	}
	zero_one(amount * weight);
}

int main()
{
	int n1, n2, n3, n4, n5, n6;
	int cnt;
	int icase = 1;
	while (~scanf("%d%d%d%d%d%d", &n1, &n2, &n3, &n4, &n5, &n6))
	{
		cnt = 0;
		if (!n1 && !n2 && !n3 && !n4 && !n5 && !n6)
		{
			break;
		}
		v = 0;
		w[1] = 1;
		num[1] = n1;
		v += num[1];
		w[2] = 2;
		num[2] = n2;
		v += num[2] * 2;
		w[3] = 3;
		num[3] = n3;
		v += num[3] * 3;
		w[4] = 4;
		num[4] = n4;
		v += num[4] * 4;
		w[5] = 5;
		num[5] = n5;
		v += num[5] * 5;
		w[6] = 6;
		num[6] = n6;
		v += num[6] * 6;
		printf("Collection #%d:\n", icase++);
		if (v & 1)
		{
			printf("Can't be divided.\n");
			printf("\n");
			continue;
		}
		v >>= 1;
		memset (dp, 0, sizeof(dp) );
		dp[0] = 0;
		for (int i = 1; i <= 6; ++i)
		{
			duochon(num[i], w[i]);
		}
		
		if (dp[v] != v)
		{
			printf("Can't be divided.\n");
		}
		else
		{
			printf("Can be divided.\n");
		}
		printf("\n");
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值