POJ2773---Happy 2006(容斥+二分)

94 篇文章 0 订阅
7 篇文章 0 订阅

Description
Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9…are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input
The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output
Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source
POJ Monthly–2006.03.26,static

二分区间上限mid,计算[1, mid]里与n互质的数个数,多次二分以后,mid的值就是第k个和n互质的数

/*************************************************************************
    > File Name: POJ2773.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月28日 星期四 19时36分15秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

vector <int> mst;

LL calc(LL high) {
    int size = mst.size();
    LL ans = 0;
    for (int i = 1; i < (1 << size); ++i) {
        int bits = 0;
        LL P = 1;
        for (int j = 0; j < size; ++j) {
            if (i & (1 << j)) {
                ++bits;
                P *= mst[j];
            }
        }
        if (bits & 1) {
            ans += high / P;
        }
        else {
            ans -= high / P;
        }
    }
    return high - ans;
}

int main() {
    LL m, k;
    while (cin >> m >> k) {
        mst.clear();
        LL tmp = m;
        for (int i = 2; i * i <= tmp; ++i) {
            if (tmp % i == 0) {
                mst.push_back(i);
                while (tmp % i == 0) {
                    tmp /= i;
                }
            }
        }
        if (tmp > 1) {
            mst.push_back(tmp);
        }
        LL ans = -1, mid;
        LL l = 1, r = (1LL << 60);
        while (l <= r) {
            mid = (l + r) >> 1;
            LL tmp = calc(mid);
            if (tmp >= k) {
                r = mid - 1;
                ans = mid;
            }
            else {
                l = mid + 1;
            }
        }
        printf("%lld\n", ans);
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值