北大ACM poj2141 Message Decowding

Message Decowding
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10326 Accepted: 5672

Description

The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:
        yrwhsoujgcxqbativndfezmlpk

Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

Input

* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded

Output

* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

Sample Input

eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj

Sample Output

Jump the fence when you seeing me coming

 字符串转换题不多说了。

#include<stdio.h>
main()
{
	char a[128],b[100],c[100];
	int i;
	int j=0;
	//freopen("in.txt","r",stdin);
	for(i='a';i<='z';i++)
	{
		scanf("%c",&a[i]);
	}
	for(i='a';i<='z';i++)
	{
		a[i-32]=a[i]-32;//复制到大写字母的区域 
	}
	getchar();
	gets(b);//输入需要转换的字符串 
	while(b[j]!='\0')//如果需要转换的字符串没有到达末尾继续转换 
	{
		if(b[j]==' ')//如果是空格,不转换 
		{
			c[j++]=b[j];
			continue;
		}
		c[j]=a[b[j]];
		j++;
	}
	c[j]='\0';//加上结束符 
	puts(c);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值