关闭

BeanDefinitionStoreException Failed to read candidate component class

标签: Exceptionjdk
177人阅读 评论(0) 收藏 举报
分类:

上了好多的国内外论坛,终于确定该异常的解决办法,记下来!

一句话: jdk.version 1.8 to 1.6,在eclipse中项目属性更改后jdk版本和编译等级后,就可以正常运行了

步骤:
1.项目右键-Properties-Java Build Path 选择 已经存在的JRE System Library[jdk1.8.*] —Edit—Alternate JRE(前提是已经将下载后的1.6版本的jdk在eclipse中配置好了)—Finish
2.项目右键-Properties-Java Compiler-Compiler compliance level : 选择1.6

以上两步搞定后可以正常测试了

jdk-6u45-windows-x64下载地址

转帖请注明出处,谢谢!

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:9552次
    • 积分:220
    • 等级:
    • 排名:千里之外
    • 原创:12篇
    • 转载:4篇
    • 译文:0篇
    • 评论:0条