数据结构实验之二叉树四:还原二叉树

数据结构实验之二叉树四:还原二叉树

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入

输入数据有多组,每组数据第一行输入 1 个正整数 N(1 <= N <= 50) 为树中结点总数,随后 2 行先后给出先序和中序遍历序列,均是长度为 N 的不包含重复英文字母 ( 区分大小写 ) 的字符串。

输出

  输出一个整数,即该二叉树的高度。

示例输入

9 
ABDFGHIEC
FDHGIBEAC

示例输出

5

提示

 

来源

 xam

示例程序

 
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
    char data;
    struct node *lchild,*rchild;
};
struct node *creat(int n,char a[],char b[])
{
    struct node *root;
    char *p;
    if(n==0)
        return NULL;
    root=(struct node *)malloc(sizeof(struct node));
    root->data=a[0];
    for(p=b;p!='\0';p++)
        if(*p==a[0])
        break;
    int t;
    t=p-b;
    root->lchild=creat(t,a+1,b);
    root->rchild=creat(n-t-1,a+t+1,p+1);
    return root;
};
int deep(struct node *root)
{
    int d=0;
    if(root)
    {
        int l1=deep(root->lchild);
        int l2=deep(root->rchild);
        d=l1>l2?l1+1:l2+1;
    }
      return d;
}
int main()
{
  int i,j,n,m,k,t;
  char a[100],b[100];
  while(scanf("%d",&n)!=EOF)
  {
      struct node *root;
      scanf("%s",a);
      scanf("%s",b);
      root=creat(n,a,b);
      m=deep(root);
      printf("%d\n",m);
  }
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值