POJ 2823 Sliding Window(滑动窗口问题__优先队列||单调队列)

34 篇文章 0 订阅
16 篇文章 0 订阅
该博客主要介绍如何解决POJ 2823题目,内容涉及利用优先队列或单调队列在滑动窗口中寻找每个位置的最大值和最小值。
摘要由CSDN通过智能技术生成

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7


<pre name="code" class="html">#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
const int maxn=1e6+100;
int a[maxn],ans1[maxn],ans2[maxn];
struct cmp1
{
	bool operator ()(int x,int y)
	{
		return a[x]>a[y];
	}
};
struct cmp2
{
	bool operator ()(int x,int y)
	{
		return a[x]<a[y];
	}
};
priority_queue<int,vector<int>,cmp1>qq1;
priority_queue<int,vector<int>,cmp2>qq2;

int main()
{
	int n,k,i,j;
	while(scanf("%d%d",&n,&k)!=EOF) {
		int kk=0;
		for(i=1;i<=n;i++) scanf("%d",&a[i]);
		for(i=1;i<=k;i++) {
			qq1.push(i);
			qq2.push(i);
		}
		ans1[++kk]=a[qq1.top()];
		ans2[kk]=a[qq2.top()];
		for(i=k+1;i<=n;i++) {
			qq1.push(i);
			qq2.push(i);
			while(i-qq1.top()>=k) qq1.pop();   //很巧妙的方法,一开始想的是怎么删去超过边界的元素。 
			ans1[++kk]=a[qq1.top()];           //换个思路,如何当前的最小值不在范围内,就把它删去!!! 
			while(i-qq2.top()>=k) qq2.pop();   //删除已经移除届的数 注意此处理解
			ans2[kk]=a[qq2.top()];             //Qmin.top()为元素最小值的下标,
 		}                                      //若i与最小值下标间相差大于等于K,即最小值元素已删除,此时应Qmin.pop(); 
		for(i=1;i<=kk;i++){ 
			if(i>1) printf(" %d",ans1[i]);
			else printf("%d",ans1[i]);
		}
		printf("\n");
		for(i=1;i<=kk;i++){
			if(i>1) printf(" %d",ans2[i]);
			else printf("%d",ans2[i]);
		}
		printf("\n");
//		while(!qq1.empty()) qq1.pop();
//		while(!qq2.empty()) qq2.pop();
	}
	return 0;
}


 


                
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值