高版本ubuntu安装低版本arm-linux-gcc

原创 2016年05月31日 21:43:13

1.下载arm-linux-gcc-3.4.1.tar.gz压缩包。

2.解压并将3.4.1文件夹移到usr/local/arm目录下。

cd usr/local
mkdir arm
chmod 777 arm
sudo cp -r  /opt/Friendlyarm/3.4.1   /usr/local/

3.配置环境变量

    (1)修改/etc/bash.bashrc文件(此文件只对当前用户适用)  

<strong>     </strong>$sudo gedit /etc/bash.bashrc

     在最后加上export PATH=$PATH:/usr/local/arm/4.4.3/bin

    (2)修改/etc/profile文件(此文件属于系统级别的环境变量,设置在里面的东西对所有用户适用

<strong>     </strong>$sudo gedit /etc/profile

    在最后加上export PATH=$PATH:/usr/local/arm/4.4.3/bin

    (3)修改/etc/environment文件

     $sudo gedit /etc/environment
    原文件应为PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin: /usr/games“

    将其改为PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/arm/4. 4.3/bin"保存退出即可


4.安装兼容库,在终端输入:

<span style="font-size:14px;">     sudo apt-get install g++-multilib</span>
5.输入arm-linux-gcc -v测试是否安装成功。




版权声明:本文为博主原创文章,未经博主允许不得转载。

linux下安装两个不同版本的交叉编译环境arm-linux-gcc4.4.3、arm-linux-gcc3.4.1,切换调用的解决

linux环境下交叉编译环境的搭建教程网上有很多,这里不再赘述。 一、将两个版本的安装文件分别解压,拷贝到路径/usr/local/arm/ 下面。 [root@aguangg arm]# cd ...
  • Aguangg_6655_la
  • Aguangg_6655_la
  • 2016年11月20日 22:22
  • 1886

把ubuntu自带的高gcc版本降到低版本(如gcc 3.4)的方法

把ubuntu自带的高gcc版本降到低版本(如gcc 3.4)的方法   2014-04-22 09:42:04|  分类: cuda |  标签:ubuntu  |举报|字号 订阅 ...
  • u011057439
  • u011057439
  • 2016年07月08日 18:04
  • 1332

ubuntu中gcc版本的降低或者升高

在ubuntu中有可能我们的gcc版本过高或者过低,需要改变到合适的版本,,, 在/usr/bin/目录下,我们可以看到一些gcc开头的文件,其中有一个是gcc,用ls命令看一下,他是个链接文件,链...
  • CHENYU123123
  • CHENYU123123
  • 2013年03月12日 08:40
  • 4826

高版本ubuntu安装低版本arm-linux-gcc

1.下载arm-linux-gcc-3.4.1.tar.gz压缩包。 2.解压并将3.4.1文件夹移到usr/local/arm目录下。 cd usr/local mkdir arm chmo...
  • h9f3d3
  • h9f3d3
  • 2016年05月31日 21:43
  • 223

ubuntu14.04下多个GCC版本的切换

Ubuntu系统使用的gcc版本随着发布版本的不同而不同,在编译Android系统时不同的版本推荐用不同的gcc去编译,那么可不可以改变系统的gcc来适应android编译环境的需求呢?答案是可以的。...
  • MENGHUANBEIKE
  • MENGHUANBEIKE
  • 2018年01月09日 00:52
  • 58

高版本内核系统(Ubuntu12.04)下编译低版本内核(2.6.30)bug解决方法

在make menuconfig配置完之后(选的默认配置),然后就make出现如下错误: gcc: 错误: elf_i386:没有那个文件或目录 make[2]: *** [arch/x86/v...
  • u012414037
  • u012414037
  • 2014年05月06日 17:15
  • 1534

Unity 高版本项目 移植到 低版本

1.打开高版本的项目 然后
  • XBWXBWXBWXBW
  • XBWXBWXBWXBW
  • 2016年01月07日 10:12
  • 2664

ubuntu 12.04中的gcc版本为4.6版本过高,降级为4.4

ubuntu 12.04中的gcc版本为4.6版本过高,降级为4.4步骤: 1. 查看gcc版本和g++版本 xumingtao@huaserver1:/usr/bin$ ls...
  • JINCHENG121
  • JINCHENG121
  • 2014年06月13日 16:09
  • 1349

ubuntu 14.04 gcc 版本的更新以及降级

最近在两台ubuntu的虚拟机里做测试,目前发现ffmpeg在ubuntu14.10带的gcc4.9.1编译好有问题,为了验证问题所在,需要更换不同版本的gcc...
  • linzhaolove
  • linzhaolove
  • 2015年05月03日 11:57
  • 3751

低版本在在高版本中运行 ------ (高版本兼容低版本)

转自 http://www.cnblogs.com/vinceoniphone/archive/2010/07/05/1771282.html 如何weak link一个framework (高版本兼...
  • linkai5696
  • linkai5696
  • 2010年07月09日 13:52
  • 2331
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:高版本ubuntu安装低版本arm-linux-gcc
举报原因:
原因补充:

(最多只允许输入30个字)