hdu 1017 A Mathematical Curiosity

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1017

 

 

题目描述:

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19116    Accepted Submission(s): 5934


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 


 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 


 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 


 

Sample Input
  
  
1 10 1 20 3 30 4 0 0
 


 

Sample Output
  
  
Case 1: 2 Case 2: 4 Case 3: 5

 

 

题意:给定n,m两个数 问有多少个有序数对(a,b)符合  0<a<b<n  且  (a^2+b^2 +m)/(ab) 是整数

 

题解:直接穷举。

 

代码:

/*
A Mathematical Curiosity
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int n=0,m=0,a=0,b=0;
int N=0,Cases=0;

/*for test*/
int test()
{
    return(0);
}

/*count the number of pairs for the (a,b)*/
int CountPair(int n,int m)
{
    int num=0;
    for(b=1;b<=n-1;b++)
    {
        for(a=1;a<b;a++)
        {
            if((a*a+b*b+m)%(a*b)==0)
            {
                num++;
            }
        }
    }
    return(num);
}

/*main process*/
int MainProc()
{
    scanf("%d",&N);
    while(N--)
    {
        Cases=0;
        while(scanf("%d%d",&n,&m)!=EOF&&(n>0||m>0))
        {
            Cases++;
            int num=CountPair(n,m);
            printf("Case %d: %d\n",Cases,num);
        }
        if(N>0)
        printf("\n");
    }
    return(0);
}

int main()
{
    MainProc();
    return(0);
}





 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值