旧版本scrapy升级新版本遇到的一些问题

原创 2015年11月18日 13:31:00

最近有新同学学抓数据,他们看的是中文文档,大概是0.25版本的,所以按照教程安装的时候,装的也是老版本的scrapy,不能用一些FilePipleline的东西,非常不方便.

他们装的时候是用apt-get安装的,升级的时候可以用apt-get remove,然后再按照英文文档里的方法安装就好了.

但是另一个同学不知道怎么安装的,scrapy直接就报错.报错信息ibutionNotFound: The 'cryptography>=0.7' distribution was not found and is required by pyOpenSSL, py一般就是这类软件不够新,所以呢,然后还有什么distutils.errors.DistutilsError: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1这种错误,其实我也不知道怎么回事.搜到了几个方法:

https://github.com/pyca/pyopenssl/issues/117

sudo apt-get install libffi-dev
sudo apt-get install libssl-dev
sudo apt-get install python-dev

http://stackoverflow.com/questions/22727782/repeatedly-failing-to-install-scrapy-and-lxml

sudo apt-get install libxslt1-dev libxslt1.1 libxml2-dev libxml2 libssl-dev
这样之后,然后升级一下setuptools,再安装新版本的scrapy就好了...

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

Scrapy升级到1.0版本

发现scrapy已经升级到1.0.1了,之前一直使用的是0.24.1 使用下面命令升级:>python -m pip install --upgrade scrapy变化待续……
  • felcon
  • felcon
  • 2015-07-08 11:24
  • 1239

Python Scrapy安装(python 版本手动更新)

Scrapy安装需要python2.7以上 若python版本为2.6,则需要更新 #下载python2.7 #wget http://python.org/ftp/python/2....

教你如何cocoapods卸载安装新版本和旧版本

我在装cocoapods会遇到各种的问题,我来教大家卸载安装最新的V1.0.1。 现在打开终端,开始我们的卸载之旅。 一.首先卸载pod which pod 得到pod的路径 sudo ...
  • wm9028
  • wm9028
  • 2016-07-08 18:29
  • 2907

Android ADT升级到17.0版本后的一些问题

以前我们在开发android程序的时候,很多情况下会导入第三方库,以前我们只要在项目的根目录下建个lib或者libs目录就可以了然后: 下面以gifview这个项目为例: 1.未添加第三方...
  • zxxjj
  • zxxjj
  • 2012-04-19 16:02
  • 948

在lunix旧版本的JDK上安装新版本

系统版本:Red Hat Enterprise Linux AS release 4 Linux内核:2.6.9-89.ELlargesmp 今天需要在服务器上跑一段java程序,在本地将程序打名...

Installshield新版本安装时卸载旧版本的安装

安装包升级问题,搞得实在头大,经过反复摸索,最终决定卸载旧的安装,安装新的程序,以达到升级目的。本方案有所局限,对于大型的安装或者配置复杂的安装不适合。本案例用IS2009,InstallScript...

Nessus旧版本与新版本的配置区别

Nessus旧版本与新版本的配置区别

新版本兼容旧版本之架构设计示例

1.背景   昨天工作,在数据库持久化方面遇到点疑惑,然后打开jar包研究源码,发现了点有趣的设计,这个框架有1.0版本内容,有2.0版本内容,“除非维护1.0版本老代码,不推荐使用1.0版本,即2...

Installshield新版本安装时卸载旧版本的安装

安装包升级问题,搞得实在头大,经过反复摸索,最终决定卸载旧的安装,安装新的程序,以达到升级目的。本方案有所局限,对于大型的安装或者配置复杂的安装不适合。本案例用IS2009,InstallScript...

Linux 卸载旧版本的 JDK 并且升级新的JDK

centos5.2自带的了jdk,但还是1.4的版本,太老掉牙了,tomcat6都没发跑起来。显然没法满足我们的要求。我们先查看一下,如下所示: [root@localhost soft]# j...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)