ZOJ 3747 Attack on Titans

Attack on Titans

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Over centuries ago, mankind faced a new enemy, the Titans. The difference of power between mankind and their newfound enemy was overwhelming. Soon, mankind was driven to the brink of extinction. Luckily, the surviving humans managed to build three walls: Wall Maria, Wall Rose and Wall Sina. Owing to the protection of the walls, they lived in peace for more than one hundred years.

But not for long, a colossal Titan appeared out of nowhere. Instantly, the walls were shattered, along with the illusory peace of everyday life. Wall Maria was abandoned and human activity was pushed back to Wall Rose. Then mankind began to realize, hiding behind the walls equaled to death and they should manage an attack on the Titans.

So, Captain Levi, the strongest ever human being, was ordered to set up a special operation squad of N people, numbered from 1 to N. Each number should be assigned to a soldier. There are three corps that the soldiers come from: the Garrison, the Recon Corp and the Military Police. While members of the Garrison are stationed at the walls and defend the cities, the Recon Corps put their lives on the line and fight the Titans in their own territory. And Military Police serve the King by controlling the crowds and protecting order. In order to make the team more powerful, Levi will take advantage of the differences between the corps and some conditions must be met.

The Garrisons are good at team work, so Levi wants there to be at least M Garrison members assigned with continuous numbers. On the other hand, members of the Recon Corp are all elite forces of mankind. There should be no more than K Recon Corp members assigned with continuous numbers, which is redundant. Assume there is unlimited amount of members in each corp, Levi wants to know how many ways there are to arrange the special operation squad.

Input

There are multiple test cases. For each case, there is a line containing 3 integers N (0 < N < 1000000), M (0 < M < 10000) and K (0 < K < 10000), separated by spaces.

Output

One line for each case, you should output the number of ways mod 1000000007.

Sample Input
3 2 2
Sample Output
5
Hint

Denote the Garrison, the Recon Corp and the Military Police as G, R and P. Reasonable arrangements are: GGG, GGR, GGP, RGG, PGG.


Author:  ZOU, Xun

Source: ZOJ Monthly, January 2014



#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#define esp 1e-6
#define inf 0x0f0f0f0f
#define LL long long  
#define imod 1000000007 

#define IG 0
#define IR 1
#define IP 2
using namespace std;
/************************************************   
   
Desiner:hl   
time:2016/02/17
Exe.Time:124MS 
Exe.Memory:5528K  
  
题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5170
  
题意:给n个士兵排队,每个士兵三种G、R、P可选,求至少有m个连续G士兵,最多有k个连续R士兵的排列的种数。
  
题解:dp递推 
************************************************/  

LL dp[1000005][4];
LL N,M,K;
LL mydp(LL u,LL v){
	LL i;
	dp[0][2]=1;	//初始化 
	dp[0][1]=dp[0][0]=0;
	for(i=1;i<=N;i++){
		LL sum=((dp[i-1][IG]+dp[i-1][IR]+dp[i-1][IP])%imod+imod)%imod;
		
		dp[i][IP]=sum%imod;
	
		if(i<=u) dp[i][IG]=sum%imod;
		if(i==u+1) dp[i][IG]=((sum-1)%imod+imod)%imod;
		if(i>u+1) dp[i][IG]=((sum-dp[i-u-1][IP]-dp[i-u-1][IR])%imod+imod)%imod;
				
		if(i<=v) dp[i][IR]=sum%imod;
		if(i==v+1) dp[i][IR]=((sum-1)%imod+imod)%imod;
		if(i>v+1) dp[i][IR]=((sum-dp[i-v-1][IG]-dp[i-v-1][IP])%imod+imod)%imod; 	
		 
		//cout<<dp[i][0]<<" "<<dp[i][1]<<" "<<dp[i][2]<<endl;
	}
	return (dp[N][IP]+dp[N][IG]+dp[N][IR])%imod;
	
}



int main(){
	LL i,j,k,l,m,n,G,R,P;
	while(~scanf("%lld%lld%lld",&N,&M,&K)){
		if(N==0&&M==0&&K==0) break;
		LL ans = mydp(N,K);
		LL ans1 =mydp(M-1,K);//cout<<ans << " "<<ans1<<endl;
		ans = (ans - ans1 +imod)%imod;
		
		printf("%lld\n",ans);	
	}
	
	return 0;
	
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值