A1108. Finding Average (20)

题目描述

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

参考代码

#include <cstdio>
#include <string.h>
#include <math.h>
#include <algorithm>

using namespace std;

const int maxn = 110;
int n;
char str[maxn];
double result = 0;
bool flag = true;
double a[maxn];
int j = 0;

bool isLegal(int len)
{
	double result1 = 0,result2 = 0;
	int found = 0;
	int count = 0;
	int low = -1;
	for(int i = 0;i<len;i++)
	{
		if(str[i] == '.')
		{
			if(i == 0)
			{
				flag = false;
			}
			low = i;
			break;
		}
		else if(str[i] == '-')
		{
			if(i == 0)
			{
				found = 1;
			}
			else
			{
				found = 0;
				flag = false;
				break;
			}
		}
		else if(str[i] >= '0' && str[i] <= '9')
		{
			result1 = result1 * 10 + str[i] - '0';
			low = i;
		}
		else
		{
			flag = false;
			break;
		}
	}
	if(flag)
	{
		for(int i = low + 1;i<len;i++)
		{
			if(!(str[i] >= '0' && str[i] <= '9'))
			{
				flag = false;
				return false;
			}
			else
			{
				result2 = result2 * 10 + str[i] - '0';
				count++;
			}
		}
	}
	else
	{
		flag = false;
		return false;
	}
	if(flag)
	{
		if(count >= 3)
		{
			flag = false;
			return false;
		}
		if(count > 0)
			result2 = result2 * pow(0.1,count);
		result = result1 + result2;
		if(found == 1)
			result = -result;
		if(abs(result) > 1000)
		{
			flag = false;
			return false;
		}
	}
	return true;
}

int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%s",str);
		flag = true;
		int l = strlen(str);
		if(isLegal(l))
		{
			a[j++] = result;
		}
		else
		{
			printf("ERROR: %s is not a legal number\n",str);
		}
	}
	if(j == 0)
	{
		printf("The average of 0 numbers is Undefined");
	}
	else if(j == 1)
	{
		printf("The average of 1 number is %.2lf",a[0]);
	}
	else
	{
		double x = 0;
		for(int i=0;i<j;i++)
		{
			x = x + a[i];
		}
		x = x / j;
		printf("The average of %d numbers is %.2lf",j,x);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值