struts2 升级报filters deprecated

原创 2013年12月04日 10:10:57

文章摘抄至http://blog.sina.com.cn/s/blog_7a0d9dca01014fn2.html

 

在struts2.3.7下,web.xml中使用

会出现
***********************************************************************
*                               WARNING!!!                            *
*                                                                     *
* >>> FilterDispatcher <<< is deprecated! Please use the new filters! *
*                                                                     *
*           This can be a source of unpredictable problems!           *
*                                                                     *
*              Please refer to the docs for more details!             *
*            http://struts.apache.org/2.x/docs/webxml.html            *
*                                                                     *
***********************************************************************
原因在于:

Class FilterDispatcher
Deprecated. Since Struts 2.1.3, use StrutsPrepareAndExecuteFilter instead or StrutsPrepareFilter and StrutsExecuteFilter if needing using the ActionContextCleanUp filter in addition to this one
解决方法,将web.xml上述代码改为:

struts2升级到Struts 2.3.15.1的步骤(最新安全版本)

最近struts安全问题影响很大啊,iteye上面也有新闻:Apache Struts团队6月底发布了Struts 2.3.15版本,由于该版本被发现存在重要的安全漏洞,因此该团队今天发布了Strut...
  • hanchuang213
  • hanchuang213
  • 2017年01月16日 16:56
  • 2162

struts2升级jar包遇到无法正常访问action的方法的问题

action name 取值为login!login.action 形式 而非login  method name 为null 解决连接 http://blog.csdn.net/achilles12...
  • u014596302
  • u014596302
  • 2015年09月15日 09:57
  • 1761

Struts2升级版本至2.5.10,高危漏洞又来了

前情概要漏洞年年有,最近特别多。2017年3月6日,Apache Struts2被曝存在远程命令执行漏洞,漏洞编号:S2-045,CVE编号:CVE-2017-5638,官方评级为高危,该漏洞是由于在...
  • zhulin2012
  • zhulin2012
  • 2017年03月13日 14:15
  • 4138

Struts2从版本2.2.1升级至2.3.15.1出现的问题

转载:http://www.cnblogs.com/liuxin-listenx/archive/2013/08/05/3238462.html 问题一 原版本Struts2.2.1中的J...
  • promise_LOVE
  • promise_LOVE
  • 2015年04月07日 16:55
  • 540

struts2升级到2.5的配置

struts2升级到2.5的配置 之前的struts版本太低,后来用想过换个后台,但是改动太大,还是升级到最新版本的struts吧,虽然有点蛋疼的经历,最终还是解决了。下面来分享...
  • qq_35661171
  • qq_35661171
  • 2017年12月21日 17:44
  • 49

Struts2升级版本至2.5.10

2017年3月6日,Apache Struts2被曝存在远程命令执行漏洞,官方评级为高危,该漏洞是由于在使用基于Jakarta插件的文件上传功能条件下,恶意用户可以通过修改HTTP请求头中的Conte...
  • qq_36617784
  • qq_36617784
  • 2017年03月31日 11:48
  • 66

Struts2的类型转换实例详解(升级)

这次主要是要完善一下,加入有多个Point输入如何处理
  • UckyK
  • UckyK
  • 2014年11月24日 12:24
  • 675

struts2升级

struts2 2.3.28.1版本升级至2.5.10.1改动
  • lllwj007
  • lllwj007
  • 2017年06月28日 19:22
  • 88

Struts2升级版本至2.5.10,高危漏洞又来了

http://blog.csdn.net/zhulin2012/article/details/61916778 前情概要 漏洞年年有,最近特别多。2017年3月6日,...
  • z69183787
  • z69183787
  • 2017年07月11日 17:21
  • 321

Struts2-Tiles 2.5.2 升级指南和通配符拓展

最近工程从Struts2.3.18升级Struts2.5.2导致相关联的插件都需要升级到相同版本,其中tiles的变化最大。 1、web.xml上 listener org.apache.strut...
  • believer123
  • believer123
  • 2016年08月30日 14:20
  • 1033
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:struts2 升级报filters deprecated
举报原因:
原因补充:

(最多只允许输入30个字)