HDOJ2069

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17881    Accepted Submission(s): 6157


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
  
  
11 26
 

Sample Output
  
  
4 13
 

母函数的表形,多了一维的硬币个数限制。



#include<stdio.h> 
#include<string.h>

int c1[251][101],c2[251][101];//第一维表示钱数,第二维表示使用的硬币的数目
int Sum[251];

int coin[6]={0,1,5,10,25,50};

int main(void)
{
	int N;
	
	c1[0][0]=1;
	for(int i=1;i<=5;i++)
	{
		for(int j=0;j<=250;j++)
		{
			for(int k=0;k*coin[i]+j<=250;k++)
			{
				for(int p=0;p+k<=100;p++)//多嵌套了一层记录硬币个数 
				{
					c2[k*coin[i]+j][p+k]+=c1[j][p];
				}
			}
		}
		for(int j=0;j<=250;j++)
		{
			for ( int k = 0; k != 101; ++ k )
             <span style="white-space:pre">		</span>{
                <span style="white-space:pre">	</span>  c1[j][k] = c2[j][k]; 
               <span style="white-space:pre">		</span>  c2[j][k] = 0;
          <span style="white-space:pre">		</span>}
		}
	}
	
	
	 for ( int j = 0; j != 251; ++ j )
	 {
            for ( int i = 0; i != 101; ++ i )
            {
               Sum[j] += c1[j][i] ;
            }
         }
     
	while(scanf("%d",&N)!=EOF)
	{
	     printf("%d\n",Sum[N]);
	}


	return 0;
}


也可以用暴力方法
#include<stdio.h>
int main()
{
    int a,b,c,d,e,count,n;
    while(scanf("%d",&n)!=EOF)
    {
        count=0;
        for(a=0;a<=100;a++)
            for(b=0;5*b<=n;b++)
                for(c=0;10*c<=n;c++)
                    for(d=0;25*d<=n;d++)
                        for(e=0;50*e<=n;e++)
                        if(a+5*b+10*c+25*d+50*e==n&&a+b+c+d+e<=100)count++;
       printf("%d\n",count);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值