HDOJ1058 Humble Numbers丑数的问题

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24222    Accepted Submission(s): 10610


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 
状态转移方程:F(n)=min(F(i)*2,F(j)*3,F(k)*5,F(m)*7)

(n>i,j,k,m)

特别的:
i,j,k,m 只有在本项被选中后才移动


ijkm的数值表示 在第该数值的答案是由ijkm个对应因素乘过的数字。


Sample Output
  
  
The 1st humble
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int ugly[5842];

int Min(int a,int b,int c,int d)
{
	int temp=(a<b?a:b);
	temp= (temp<c?temp:c);
	
	return (temp<d?temp:d);
}


int main()
{

	int N;
	
	ugly[0]=1;

	int index2=0;
	int index3=0;
	int index5=0;
	int index7=0;
	
	int index=1;
	
	while(index<5842)
	{
			int val=Min(ugly[index2]*2,ugly[index3]*3,ugly[index5]*5,ugly[index7]*7);
			
			if(val==ugly[index2]*2)
				index2++;
			if(val==ugly[index3]*3)
				index3++;
			if(val==ugly[index5]*5)
				index5++;
			if(val==ugly[index7]*7)
				index7++;
				
			ugly[index++]=val;
	}
		
	while(scanf("%d",&N)&&N!=0)
	{
		
		if(N % 10 == 1 && N % 100 != 11)
			printf("The %dst humble number is %d.\n",N,ugly[N-1]);
		else if(N % 10 == 2 && N % 100 != 12)
			printf("The %dnd humble number is %d.\n",N,ugly[N-1]);
		else if(N % 10 == 3 && N % 100 != 13)
			printf("The %drd humble number is %d.\n",N,ugly[N-1]);
		else 
			printf("The %dth humble number is %d.\n",N,ugly[N-1]);
	}
	
	
	return 0;
}

number is 1.The 2nd humble number is 2.The 3rd humble number is 3.The 4th humble number is 4.The 11th humble number is 12.The 12th humble number is 14.The 13th humble number is 15.The 21st humble number is 28.The 22nd humble number is 30.The 23rd humble number is 32.The 100th humble number is 450.The 1000th humble number is 385875.The 5842nd humble number is 2000000000.
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了小程序应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值