hdoj.1695 GCD【莫比乌斯反演】 2015/04/14

这篇博客深入探讨了如何使用莫比乌斯反演解决hdoj.1695题目中的最大公约数问题。内容主要围绕GCD(最大公约数)的概念,并通过实例解析了莫比乌斯反演在求解过程中的关键步骤和思路。
摘要由CSDN通过智能技术生成

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6711    Accepted Submission(s): 2446


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
Source
#include<stdio.h>
#include<string.h>
#define MAXN 100005
int prime[MAXN];
int mu[MAXN];
int vis[MAXN];
void Init(){ // 莫比乌斯函数 
    memset(vis,0,sizeof(vis));
    mu[1] = 1;
    int cnt = 0;
    for( int  i = 2 ; i < MAXN ; ++i ){
        if( !vis[i] ){    // 素数全部记录为0 
            prime[cnt++] = i;
            mu[i] = -1;    // 素数全部为-1 
        }
        for( int j = 0 ; j < cnt && i*prime[j] < MAXN ; ++j ){    // 非素数
            vis[i*prime[j]] = 1;
            if( i % prime[j] )
                mu[i*prime[j]] = - mu[i];
            else {
                mu[i*prime[j]] = 0;
                break;
            }
        }
    }
}
int main(){
    int t,i,j,k,a,b,c,d,e;
    long long ans1,ans2;
    Init();
    scanf("%d",&t);
    for( k = 1 ; k <= t ; ++k ){
        scanf("%d %d %d %d %d",&a,&b,&c,&d,&e);
        printf("Case %d: ",k);
        if( e == 0 ){
            printf("0\n");
            continue;
        }
        if( b > d ){ // 交换b与d的值,使d最大 
            a = b;
            b = d;
            d = a;
        }
        b/=e;
        d/=e;
        ans1 = ans2 = 0;
        for( i = 1 ; i <= b ; ++i )
            ans1 += (long long)mu[i]*(b/i)*(d/i);
        for( i = 1 ; i <= b ; ++i )
            ans2 += (long long)mu[i]*(b/i)*(b/i);
        printf("%lld\n",ans1-ans2/2);
    }
    return 0;
}

题意读懂了,但是没想到居然是莫比乌斯反演,完全没听过啊,去网上搜了一下,看不懂,看了整整一晚上,有了一点点的头绪,再把代码运行一遍,才理解莫比乌斯函数的意义,才发现自己知道的真少,压力又大了( ╯□╰ )
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值