九度 Prime Ring Problem hdu 1016

70 篇文章 0 订阅
29 篇文章 0 订阅

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1016

题目来源:http://ac.jobdu.com/problem.php?pid=1459

时间限制:2 秒

内存限制:128 兆

特殊判题:

提交:803

解决:330

题目描述:

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.


输入:

n (1 < n < 17).

输出:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

样例输入:
6
8
样例输出:
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
提示:

用printf打印输出。

回溯搜索

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN = 50;

int IsPrime[MAXN], visit[MAXN>>1];

void PreCheckPrime()
{
    int i, j;
    for(i = 0; i < MAXN; ++i)
        IsPrime[i] = 1;
    IsPrime[0] = IsPrime[1] = 0;
    for(i = 2; i < MAXN; ++i)
    {
        if(IsPrime[i])
        {
            for(j = i+i; j < MAXN; j += i)
                IsPrime[j] = 0;
        }
    }
}

void Print_Prime_Ring(int* arr, int n)
{
    for(int i = 1; i < n; ++i)
        printf("%d ", arr[i]);
    printf("%d\n", arr[n]);
}

void FindPrimeRing(int n, int index, int* arr)
{
    if(index == n+1)
    {
        if(IsPrime[arr[index-1] + 1])
            Print_Prime_Ring(arr, n);
        return ;
    }
    for(int i = 2; i <= n; ++i)
    {
        if(!visit[i] && IsPrime[i+arr[index-1]])
        {
            visit[i] = 1;
            arr[index] = i;
            FindPrimeRing(n, index+1, arr);
            visit[i] = 0;
        }
    }
}

int main()
{
    int n, kcase = 1;
    PreCheckPrime();
    while(~scanf("%d", &n))
    {
        printf("Case %d:\n", kcase++);
        int arr[MAXN];
        memset(visit, 0, sizeof(visit));
        arr[1] = 1;
        visit[1] = 1;
        FindPrimeRing(n, 2, arr);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值