题目1201:二叉排序树

题目来源:http://ac.jobdu.com/problem.php?pid=1201

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3039

解决:1279

题目描述:

    输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入:

    输入第一行包括一个整数n(1<=n<=100)。
    接下来的一行包括n个整数。

输出:

    可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。
    每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入:
5
1 6 5 9 8
样例输出:
1 6 5 9 8 
1 5 6 8 9 
5 8 9 6 1 
提示:

输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。

来源:
2005年华中科技大学计算机保研机试真题
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

struct Binary_Search_Tree_Node
{
    Binary_Search_Tree_Node* pRChildren;
    Binary_Search_Tree_Node* pLChildren;
    int data;
    Binary_Search_Tree_Node()
    {
        pRChildren = pLChildren = NULL;
        data = 0;
    }
};

bool In_BST(Binary_Search_Tree_Node* pRoot, Binary_Search_Tree_Node* &p, int data, Binary_Search_Tree_Node* f)
{
    if(pRoot == NULL)
    {
        p = f;
        return false;
    }
    if(data == pRoot->data)
    {
        p = pRoot;
        return true;
    }
    else if(data > pRoot->data)
        return In_BST(pRoot->pRChildren, p, data, pRoot);
    else if(data < pRoot->data)
        return In_BST(pRoot->pLChildren, p, data, pRoot);
    return false ;
}


void Insert_BST(Binary_Search_Tree_Node* &pRoot, int iData)
{
    Binary_Search_Tree_Node* p = NULL;
    if(!In_BST(pRoot, p, iData, NULL))
    {
        Binary_Search_Tree_Node* tmp = new Binary_Search_Tree_Node();
        tmp->data = iData;
        if(p == NULL)
            pRoot = tmp;
        else if(p->data > iData)
            p->pLChildren = tmp;
        else if(p->data < iData)
            p->pRChildren = tmp;
    }
}

void Pre_Print_Binary_Search_Tree(Binary_Search_Tree_Node* pRoot)
{
    if(pRoot == NULL)
        return ;
    printf("%d ", pRoot->data);
    Pre_Print_Binary_Search_Tree(pRoot->pLChildren);
    Pre_Print_Binary_Search_Tree(pRoot->pRChildren);
}

void InOrder_Print_Binary_Search_Tree(Binary_Search_Tree_Node* pRoot)
{
    if(pRoot == NULL)
        return ;
    InOrder_Print_Binary_Search_Tree(pRoot->pLChildren);
    printf("%d ", pRoot->data);
    InOrder_Print_Binary_Search_Tree(pRoot->pRChildren);
}

void PostOrder_Print_Binary_Search_Tree(Binary_Search_Tree_Node* pRoot)
{
    if(pRoot == NULL)
        return ;
    PostOrder_Print_Binary_Search_Tree(pRoot->pLChildren);
    PostOrder_Print_Binary_Search_Tree(pRoot->pRChildren);
    printf("%d ", pRoot->data);
}

void Delete_Binary_Search_Tree(Binary_Search_Tree_Node* pRoot)
{
    if(pRoot ==  NULL)
        return ;
    if(pRoot->pLChildren == NULL && pRoot->pRChildren == NULL)
    {
        delete pRoot;
        return ;
    }
    Delete_Binary_Search_Tree(pRoot->pLChildren);
    Delete_Binary_Search_Tree(pRoot->pRChildren);
}

int main()
{
    Binary_Search_Tree_Node* pRoot;
    int iData, n;
    while(~scanf("%d", &n))
    {
        pRoot = NULL;
        for(int i = 0; i < n; ++i)
        {
            scanf("%d", &iData);
            Insert_BST(pRoot, iData);
        }
        Binary_Search_Tree_Node* tmp = pRoot;
        Pre_Print_Binary_Search_Tree(tmp);
        printf("\n");
        tmp = pRoot;
        InOrder_Print_Binary_Search_Tree(tmp);
        printf("\n");
        tmp = pRoot;
        PostOrder_Print_Binary_Search_Tree(tmp);
        printf("\n");
        Delete_Binary_Search_Tree(pRoot);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我可以为您提供帮助。下面是二叉排序树的链表实现代码。 ```c #include <stdio.h> #include <stdlib.h> typedef struct TreeNode { int data; struct TreeNode* left; struct TreeNode* right; } TreeNode; // 插入节点 void insertNode(TreeNode** root, int data) { if (*root == NULL) { *root = (TreeNode*)malloc(sizeof(TreeNode)); (*root)->data = data; (*root)->left = NULL; (*root)->right = NULL; } else { if (data < (*root)->data) { insertNode(&((*root)->left), data); } else if (data > (*root)->data) { insertNode(&((*root)->right), data); } } } // 查找节点 TreeNode* searchNode(TreeNode* root, int data) { if (root == NULL) { return NULL; } else if (data == root->data) { return root; } else if (data < root->data) { return searchNode(root->left, data); } else { return searchNode(root->right, data); } } // 删除节点 TreeNode* deleteNode(TreeNode* root, int data) { if (root == NULL) { return NULL; } else if (data < root->data) { root->left = deleteNode(root->left, data); } else if (data > root->data) { root->right = deleteNode(root->right, data); } else { if (root->left == NULL && root->right == NULL) { free(root); root = NULL; } else if (root->left == NULL) { TreeNode* temp = root; root = root->right; free(temp); } else if (root->right == NULL) { TreeNode* temp = root; root = root->left; free(temp); } else { TreeNode* temp = root->right; while (temp->left != NULL) { temp = temp->left; } root->data = temp->data; root->right = deleteNode(root->right, temp->data); } } return root; } // 销毁二叉排序树 void destroyTree(TreeNode** root) { if (*root != NULL) { destroyTree(&((*root)->left)); destroyTree(&((*root)->right)); free(*root); *root = NULL; } } // 中序遍历 void inorderTraversal(TreeNode* root) { if (root != NULL) { inorderTraversal(root->left); printf("%d ", root->data); inorderTraversal(root->right); } } int main() { TreeNode* bst = NULL; // 插入节点 insertNode(&bst, 6); insertNode(&bst, 2); insertNode(&bst, 8); insertNode(&bst, 1); insertNode(&bst, 5); insertNode(&bst, 3); // 中序遍历 printf("Inorder traversal: "); inorderTraversal(bst); printf("\n"); // 查找节点 TreeNode* node = searchNode(bst, 3); if (node != NULL) { printf("Found node: %d\n", node->data); } else { printf("Node not found.\n"); } // 删除节点 bst = deleteNode(bst, 2); printf("Inorder traversal after deleting node 2: "); inorderTraversal(bst); printf("\n"); // 销毁二叉排序树 destroyTree(&bst); return 0; } ``` 在主函数中,我们首先创建一个空的二叉排序树,然后插入一些节点。使用中序遍历函数输出二叉排序树的内容,查找一个节点,删除一个节点,再次使用中序遍历函数输出二叉排序树的内容,最后销毁二叉排序树。您可以根据自己的需要进行修改和扩展。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值