九度 题目1436:Repair the Wall

70 篇文章 0 订阅
21 篇文章 0 订阅

题目来源:http://ac.jobdu.com/problem.php?pid=1436

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:1004

解决:415

题目描述:

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is 
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

输入:

The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

输出:

For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.

样例输入:
5 3
3 2 1
5 2
2 1
样例输出:
2
impossible
本题是一道贪心题,尽可能的选长度最大的就可以了,因此要先降序排一下序!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAXN = 610;

bool cmp(int a, int b)
{
    return a > b;
}

int main()
{
    int iLen, arr[MAXN], n, i, iSumLen, iNum;
    while(~scanf("%d %d", &iLen, &n))
    {
        bool flag = false;
        for(i = 0; i < n; ++i)
            scanf("%d", &arr[i]);
        sort(arr, arr+n, cmp);
        iSumLen = 0, iNum = 0;
        for(i = 0; i < n; ++i)
        {
            iSumLen += arr[i];
            iNum++;
            if(iSumLen >= iLen)
            {
                flag = true;
                break;
            }
        }
        if(flag)
            printf("%d\n", iNum);
        else
            printf("impossible\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值