hdu 2001计算两点间的距离

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2001

计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 111553    Accepted Submission(s): 42558


Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 

Output
对于每组输入数据,输出一行,结果保留两位小数。
 

Sample Input
  
  
0 0 0 1 0 1 1 0
 

Sample Output
  
  
1.00 1.41
 

Author
lcy
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1091  1090  1092  1096  1089 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

float Abs(float a)
{
    return a >= 0 ? a : (-a);
}

int main()
{
    float x1, x2, y1, y2;
    while(~scanf("%f %f %f %f", &x1, &y1, &x2, &y2))
    {
        float d = sqrt(Abs((x2-x1) * (x2-x1) + (y2-y1) * (y2-y1)));
        printf("%.2f\n", d);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值