ActivityWrongDbException:version mismatch:activiti library version is '5.11',db version is null Hint

原创 2016年08月30日 17:09:15

最近工作中遇到个很奇怪的问题,项目总是报ActivityWrongDbException:version mismatch:activiti library version is '5.11',db version is null Hint,再网上找了很久也没有找到合适的答案,最后被折磨了一天终于找到了问题所在,在这记录下:


这个是由于数据库内的版本跟实际的版本不匹配导致的(ACT_GE_PROPERTY表),我这是由于导数据的时候该表数据部分未导入成功,导致一直报改错误,该表修改为:

后问题解决。记录下,以便下次更好的解决。

版权声明:本文为博主原创文章,未经博主允许不得转载。

关于activiti报:org.activiti.engine.ActivitiException: couldn't find type for XXX 异常的问题

从activiti论坛的相关讨论中可以得知,activiti报这个异常的原因多是因为XXX类型可能做为Variable设给了工作流,而这个XXX类型并没有序列化!知道原因后,解决方法就很简单了,只需要...

Version of activiti database (5.15.1) is more recent than the engine (5.14)

org.activiti.engine.ActivitiException: Version of activiti database (5.15.1) is more recent than the...

java.lang.NoSuchMethodError: javax.persistence.Table.indexes()[Ljavax/persistence/Index;

使用hibernate4.3 出现这种问题,通过对比,我发现在model类中如果使用了Table(name="t_user"),就会报这样的错误,但是如果我写成@Entity(name="t_user...

java.lang.NoSuchMethodError: javax.persistence.Table.indexes()

在配置hibernate的时候出现了如下错误: Java.lang.NoSuchMethodError: javax.persistence.Table.indexes() 错误原因: @Table...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:ActivityWrongDbException:version mismatch:activiti library version is '5.11',db version is null Hint
举报原因:
原因补充:

(最多只允许输入30个字)