字典树

Problem E

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 102400/204800K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i'm from mars.
i like earth!

代码:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <time.h>
#include <conio.h>
 
typedef struct Trie
{
    int flag;
    Trie *child[26];
    char *translation;
} root, node;
 
root *init(  )
{
    root *r= ( root * )malloc( sizeof( root ) );
    r->flag= 0;
    memset( r-> child, 0, sizeof( r-> child ) );
    return r;
}
 
void insert( node *parent, char *in, char *trans )
{
    if( *in== '\0' )
    {
        parent-> flag= 1;
        parent-> translation= trans;
        return;
    } 
    if( !parent-> child[ *in- 'a' ] )
        parent-> child[ *in- 'a' ]= init(  ); 
         
    insert( parent-> child[ *in- 'a' ], in+ 1, trans );
}
 
bool search( node *parent, char *in )
{
    if( *in== '\0' )
    {
        if( parent-> flag== 1 )
        {
            printf( "%s", parent-> translation );
            return true;
        }
        else
            return false;
    }
    if( !parent-> child[ *in- 'a' ] ) 
        return false; 
    else
        search( parent-> child[ *in- 'a' ], in+ 1 ); 
}
 
bool legal( char chr )
{
    if( chr>= 'a'&& chr<= 'z' )
        return true;
    else
        return false;
}
 
int main()
{
    char en[12], mar[12], words[3005];
    scanf( "%s", en );
    root *r= init(  );
    while( scanf( "%s", en ), strcmp( en, "END" ) )
    {
        char *trans= ( char * )malloc( sizeof( en ) );
        strcpy( trans, en );
        scanf( "%s", mar );
        insert( r, mar, trans );
    }
    scanf( "%s%*", en );
    char c, temp[12];
    int cnt= 0;
    while( c= getchar(  ) )
    {
        if( ( c< 'a'|| c> 'z' )&&( c< 'A'|| c> 'Z' ) )
        {
            temp[cnt]= '\0';
            if( !strcmp( temp, "END" ) )
                break;
            if( !search( r, temp ) )
                printf( "%s", temp );
            printf( "%c", c );
            cnt= 0;
        }
        else
        {
            temp[cnt++]= c;
        }
    }
    return 0;
}

本体应用一个map容器可以很方便的解答,还有就是字符数组的应用
#include"iostream"
#include"string" 
#include"map" 
using namespace std;
int main() 
{
 string a,b; 
 map<string ,string>m; 
 cin>>a; 
 while(cin>>a&&a!="END")
 {
 cin>>b;
 m[b]=a; 
 } 
 cin>>a;
 char tem[3001];
 getchar(); 
 while(1) 
 {
  gets(tem);
  if(strcmp(tem,"END")==0)
  break;
  int i,len;
  len=strlen(tem);
  b="";
  for(i=0;i<len;i++)
  { 
   if(tem[i]<'a'||tem[i]>'z')
   {
    if(m[b]!="") 
    cout<<m[b];
    else 
    cout<<b;
    b="";
    cout<<tem[i]; 
    } 
    else
    b+=tem[i]; 
  }
  cout<<endl; 
 } 
 return 0;
很容易看出字典树占用内存更多,但查找速度很快。第二种方法则相反。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值