HDOJ 1075 What Are You Talking About (字典树映射)

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 17943    Accepted Submission(s): 5836


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
  
  
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended. 贼烦这题,输入什么的要疯了, 思路:因为要找对应,所以直接在单词的最后复制上所对应的的单词,到时候直接查找返回单词所在结点 ac代码:  
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stack>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define LL long long
#define MAXN 4000
#define mem(x) memset(x,0,sizeof(x))
#define INF 0xfffffff 
using namespace std;
struct s
{
    char word[21];
    s *next[26];
};
s *root;
char str[MAXN],ss[MAXN];
void create(char *str,char *ss)
{
    int len=strlen(ss);
    s *p=root,*q;
    for(int i=0;i<len;i++)
    {
        int id=ss[i]-'a';
        if(p->next[id]==NULL)
        {
            q=(s *)malloc(sizeof(s));
            for(int j=0;j<26;j++)
            q->next[j]=NULL;
            strcpy(q->word,"");
            p->next[id]=q;
            p=p->next[id];
        }
        else
        {
            p=p->next[id];
        }
    }
    strcpy(p->word,str);
}
s *find(char *sq)
{
    int len=strlen(sq);
    s *p=root;
    for(int i=0;i<len;i++)
    {
        int id=sq[i]-'a';
        //p=p->next[id];
        if(p->next[id]==NULL)
        return NULL;
        p=p->next[id];
    }
    if(strcmp(p->word,""))
    return p;
    return NULL;
}
void begin()
{
    for(int i=0;i<26;i++)
    root->next[i]=NULL;
}
void freetree(s *t)
{
    if(t==NULL)
    return;
    for(int i=0;i<26;i++)
    {
        if(t->next[i]!=NULL)
        freetree(t->next[i]);
    }
    free(t);
    return;
}
int main()
{
    root=(s *)malloc(sizeof(s));
    begin();
    strcpy(root->word,"");
    while(scanf("%s",str)!=EOF)
    {
        if(str[0]=='S')
        continue;
        if(str[0]=='E')
        break;
        scanf("%s",ss);
        create(str,ss);
    }
//    if(p!=NULL)
//    printf("111");
//    else
//    printf("000");
    getchar();
    while(gets(str))
    {
        //getchar();
        if(str[0]=='S')
        continue;
        if(str[0]=='E')
        break;
        int len=strlen(str);
        char ne[MAXN];
        mem(ne);
        for(int i=0;i<len;i++)
        {
            if(str[i]>='a'&&str[i]<='z')
            {
                int k=i;
                int j=0;
                while(k<len&&str[k]>='a'&&str[k]<='z')
                ne[j++]=str[k++];
                ne[j]='\0';
                //printf("%s",ne);
                s *p=find(ne);
                if(p!=NULL)
                printf("%s",p->word);
                else
                {
                    for(int q=i;q<k;q++)
                    printf("%c",str[q]);
                }
                i=k-1;
                mem(ne);
            }
            else
            printf("%c",str[i]);
        }
        printf("\n");
    }
    freetree(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值