UVA 548 Tree(二叉树的建立)


  Tree 

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output 

1
3
255

题目意思:

给定一颗二叉树后序和中序,求出这颗二叉树从根节点到叶子点的和的最小值,输出最小值的叶子节点的值

解题思路:

1利用模板建立一颗二叉树

2 遍历求最小的和的叶子节点的值

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <string>
#include <sstream>
using namespace std;

const int maxv = 10000 + 10;

int in_order[maxv],post_order[maxv];

int lch[maxv],rch[maxv];

int n;

bool read_list(int a[]) {
	string line;
	if(!getline(cin,line))
		return false;
	stringstream ss(line);
	n = 0;
	int x;
	while(ss >> x)
		a[n++] = x;
	return n > 0;
}

//把in_order[L1..R1]和post_order[L2..R2]建成一颗二叉树,返回树根
int build(int L1,int R1,int L2,int R2) {
	
	if(L1 > R1)
		return 0;
	int root = post_order[R2];
	int p = L1;
	while(in_order[p] != root)
		p++;
	int cnt = p - L1;
	
	lch[root] = build(L1 , p-1, L2 , L2+cnt-1);
	rch[root] = build(p+1, R1 , L2+cnt, R2-1);
	
	return root;
}

int best,best_sum;

void dfs(int u,int sum) {
	sum += u;
	if(!lch[u] && !rch[u]) { //叶子
		if(sum < best_sum || (sum == best_sum && u < best)) {
			best = u;
			best_sum = sum;
		}	
	}
	if(lch[u])
		dfs(lch[u],sum);
	if(rch[u])
		dfs(rch[u],sum);
}

int main() {
	while(read_list(in_order)) {
		read_list(post_order);
		build(0,n-1,0,n-1);
		best_sum = 0x3f3f3f;
		dfs(post_order[n-1],0);
		cout<<best<<endl;
	}
	return 0;
}


用建立二叉树的方法来完成该题

#include <cstdio>
#include <ctype.h>
#include <cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
const int N = 100000;
struct Node {
	int val;
	Node* left;
	Node* right;
	Node() {
		val = 0;
		left = NULL;
		right = NULL;
	}
	Node(int _val) {
		val = _val;
		left = NULL;
		right = NULL;
	}
};
int post_order[N],in_order[N];
int getNum(char str[],int num[]) {
	int cnt = 0;
	for(int i = 0; str[i]; i++) {
		while(str[i] == ' ') {
			i++;
		}
		num[cnt] = 0;
		while(isdigit(str[i]) && str[i]) {
			num[cnt] = num[cnt]*10 + (str[i] - '0');
			i++;
		}
		cnt++;
		if(!str[i]) {
			break;
		}
	}
	return cnt;
}
//建立二叉树,l1,r1为in_order,l2,r2为post_order
Node* build(Node* root,int l1,int r1,int l2,int r2) {
	if(l2 > r2) {
		return NULL;
	}
	root = new Node(post_order[r2]);
	int p = l1;
	while(in_order[p] != post_order[r2]) {
		p++;
	}
	int dis = p - l1;
	root->left = build(root->left,l1, l1+p-1, l2, l2+dis-1);
	root->right = build(root->right,p+1, r1, l2+dis, r2-1);
	return root;
}
int ans,max;
void dfs(Node* root,int sum) {
	sum += root->val;
	if(root->left == NULL && root->right == NULL) {
		if(sum < max || (sum == max && root->val < ans)) {
			ans = root->val;
			max = sum;
		}
	}
	if(root->left != NULL) {
		dfs(root->left,sum);
	}
	if(root->right != NULL) {
		dfs(root->right,sum);
	}
}
int main() {
	char str[N];
	while(gets(str)) {
		int n = getNum(str,in_order);
		gets(str);
		getNum(str,post_order);
		Node* root = NULL;
		root = build(root,0,n-1,0,n-1);
		max = INF;
		dfs(root,0);
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值