UVA - 216 Getting in Line (全排列枚举 和 回溯两种解法)

 Getting in Line 

Computer networking requires that the computers in the network be linked.

This problem considers a ``linear" network in which the computers are chained together so that each is connected to exactly two others except for the two computers on the ends of the chain which are connected to only one other computer. A picture is shown below. Here the computers are the black dots and their locations in the network are identified by planar coordinates (relative to a coordinate system not shown in the picture).

Distances between linked computers in the network are shown in feet.

For various reasons it is desirable to minimize the length of cable used.

Your problem is to determine how the computers should be connected into such a chain to minimize the total amount of cable needed. In the installation being constructed, the cabling will run beneath the floor, so the amount of cable used to join 2 adjacent computers on the network will be equal to the distance between the computers plus 16 additional feet of cable to connect from the floor to the computers and provide some slack for ease of installation.

The picture below shows the optimal way of connecting the computers shown above, and the total length of cable required for this configuration is (4+16)+ (5+16) + (5.83+16) + (11.18+16) = 90.01 feet.

Input

The input file will consist of a series of data sets. Each data set will begin with a line consisting of a single number indicating the number of computers in a network. Each network has at least 2 and at most 8 computers. A value of 0 for the number of computers indicates the end of input.

After the initial line in a data set specifying the number of computers in a network, each additional line in the data set will give the coordinates of a computer in the network. These coordinates will be integers in the range 0 to 150. No two computers are at identical locations and each computer will be listed once.

Output

The output for each network should include a line which tells the number of the network (as determined by its position in the input data), and one line for each length of cable to be cut to connect each adjacent pair of computers in the network. The final line should be a sentence indicating the total amount of cable used.

In listing the lengths of cable to be cut, traverse the network from one end to the other. (It makes no difference at which end you start.) Use a format similar to the one shown in the sample output, with a line of asterisks separating output for different networks and with distances in feet printed to 2 decimal places.

Sample Input

6
5 19
55 28
38 101
28 62
111 84
43 116
5
11 27
84 99
142 81
88 30
95 38
3
132 73
49 86
72 111
0

Sample Output

**********************************************************
Network #1
Cable requirement to connect (5,19) to (55,28) is 66.80 feet.
Cable requirement to connect (55,28) to (28,62) is 59.42 feet.
Cable requirement to connect (28,62) to (38,101) is 56.26 feet.
Cable requirement to connect (38,101) to (43,116) is 31.81 feet.
Cable requirement to connect (43,116) to (111,84) is 91.15 feet.
Number of feet of cable required is 305.45.
**********************************************************
Network #2
Cable requirement to connect (11,27) to (88,30) is 93.06 feet.
Cable requirement to connect (88,30) to (95,38) is 26.63 feet.
Cable requirement to connect (95,38) to (84,99) is 77.98 feet.
Cable requirement to connect (84,99) to (142,81) is 76.73 feet.
Number of feet of cable required is 274.40.
**********************************************************
Network #3
Cable requirement to connect (132,73) to (72,111) is 87.02 feet.
Cable requirement to connect (72,111) to (49,86) is 49.97 feet.
Number of feet of cable required is 136.99.


题目大意:给你n个节点和节点的坐标,每个节点代表一个电脑,现在要你把所有电脑连成一条线,使得所用的电缆总长度最小。

两台电脑之间由一条缆线连接, 缆线的长度除了这两点间的直线长度,还要额外加上16米长。


解析:直接用全排列暴力枚举出所有的可能情况,求出最小的值。


#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
using namespace std;
const int N = 10;
const int INF = 0x3f3f3f;
struct Node{
	int x;
	int y;
	int id;
}a[N],b[N];

double fun(Node a,Node b) {
	return sqrt( (a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y)) + 16;
}
bool cmp(Node a,Node b) {
	return a.id < b.id;
}
int main() {
	int n;
	int cas = 1;
	double min,sum;
	while(scanf("%d",&n) != EOF && n) {
		for(int i = 0; i < n; i++) {
			scanf("%d%d",&a[i].x,&a[i].y);
			a[i].id = i;
		}
		min = INF,sum;
		do {
			sum = 0;
			for(int i = 0; i < n-1; i++) {
				double tmp = fun(a[i],a[i+1]);
				sum += tmp;
			}
			if( sum < min) {
				min = sum;
				for(int i = 0; i < n; i++) {
					b[i] = a[i];
				}
			}
		} while( next_permutation(a,a+n,cmp) );
		printf("**********************************************************\n");
		printf("Network #%d\n",cas++);
		for(int i = 0; i < n-1; i++) {
			printf("Cable requirement to connect (%d,%d) to (%d,%d) is %.2lf feet.\n",b[i].x,b[i].y,b[i+1].x,b[i+1].y,fun(b[i],b[i+1]) );
		}
		printf("Number of feet of cable required is %.2lf.\n",min);
	}
	return 0;
}

还有一种解法是更高效的回溯法,但是相对于暴力枚举更难想到,为什么回溯求解更高效呢?

因为回溯求解,剪掉了中间不必要的部分,即当sum >= min时这部分,没有必要判断,相对于全排列枚举出所有的可能,回溯判断的情况更少,所以更快。


#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
const int INF = 0x3f3f3f;
const int N = 10;

struct Node{
	int x,y;
}node[N];

int n;
int vis[N],id[N],t[N];
double min;

double fun(Node a,Node b) {
	return sqrt( (a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y)) + 16;
}

void dfs(int cur,double sum) {
	if(cur == n) {
		if(sum < min) {
			min = sum;
			for(int i = 0; i < n; i++) {
				t[i] = id[i];
			}
		}
		return ;
	}
	if(sum >= min) {
		return ;
	}
	for(int i = 0; i < n; i++) {
		if(vis[i]) {
			continue;
		}
		vis[i] = 1;
		id[cur] = i;
		if(cur == 0) {
			dfs(cur+1,0);
		}else {
			double l = fun(node[id[cur-1]],node[id[cur]]);
			dfs(cur+1,sum+l);
		}
		vis[i] = 0;
	}
}

int main() {
	int cas = 1;
	while(scanf("%d",&n) != EOF && n) {
		for(int i = 0; i < n; i++) {
			scanf("%d%d",&node[i].x,&node[i].y);
		}
		memset(vis,0,sizeof(vis));
		min = INF;
		dfs(0,0);
		//output
		printf("**********************************************************\n");
		printf("Network #%d\n",cas++);
		for(int i = 0; i < n-1; i++) {
			printf("Cable requirement to connect (%d,%d) to (%d,%d) is %.2lf feet.\n",node[t[i]].x,node[t[i]].y,node[t[i+1]].x,node[t[i+1]].y,fun(node[t[i]],node[t[i+1]]));
		}
		printf("Number of feet of cable required is %.2lf.\n",min);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值