HDU1005 Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2
5
一开始准备用循环求,但是总是出问题,后来发现这个题目得出的数列有周期。

例如a=1,b=1时,数列依次等于1,1,2,3,5,1,6,0,6,6,5,4,2,6,1,0;周期为16;

所以这道题可以先依次求出f(i),当f(i)=f(i-1)=1时,就找完了整个周期,而此时i-2就是周期。

代码如下:

#include <stdio.h>
#include <stdlib.h>
#define N 1000
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char *argv[]) 
{
	int f[1000];
	int i,n,a,b;
	f[1]=1;f[2]=1;
	while(scanf("%d%d%d",&a,&b,&n)!=-1)
	{
		if(a==0&&b==0&&n==0)
			break;
		if(n==1||n==2)
		{
			printf("1\n");
			continue;
		}
		for(i=3;i<200;i++)
		{
			f[i]=(a*f[i-1]+b*f[i-2])%7;
			if(f[i]==1&&f[i-1]==1)
				break;
		}
		i-=2;
		f[0]=f[i];
		printf("%d\n",f[n%i]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值