关闭

ubuntu使用方法积累

147人阅读 评论(0) 收藏 举报
分类:

改变文件所属用户及用户组

sudo chown -R username filename
sudo chgrp -R groupname filename

环境变量

#环境变量
PATH = $PATH:/usr/local/bin
#共享库
LD_LIBRARY_PATH = $LD_LIBRARY_PATH:/usr/local/lib

deb依赖问题

wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
sudo dpkg -i bcloud-x.x.x.deb
sudo apt-get -f install

no version information available

ubuntu下编译代码通过,然而在运行时报错:no version information available。
1.这主要是编译时使用的makefile中引用的动态链接库和实际运行时使用的动态链接库不同造成的。可以查看可执行文件动态链接库然后与makefile文件中的动态链接库对比,因此在LD_LIBRARY_PATH中加入动态链接库的位置即可。这样运行时就会首先查找path中的动态链接库从而找到正确的动态链接库,程序也恢复正常。

ldd executablefile

2.有时候问题更复杂一些,引用的动态链接库在编译时调用的动态链接库与你使用的不同。这是需要将动态链接库的软链接到正确的位置。

ln -s 目标动态链接库 软链接名称

gedit中文乱码

  1. 打开终端,输入命令:
    gsettings set org.gnome.gedit.preferences.encodings auto-detected "['GB18030', 'UTF-8', 'CURRENT', 'ISO-8859-15', 'UTF-16']"
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:2434次
    • 积分:120
    • 等级:
    • 排名:千里之外
    • 原创:7篇
    • 转载:1篇
    • 译文:0篇
    • 评论:0条
    文章分类