关闭

将“EntityFramework 5.0.0”更新到“EntityFramework 6.1.3”失败。找不到与“EntityFramework 6.1.3”兼容的“EntityFramework.

2406人阅读 评论(0) 收藏 举报
分类:

从NuGet上下载安装EF,提示兼容版本,提醒信息如下:

PM> install-package entityframework
正在安装“EntityFramework 6.1.3”。 您正在从Microsoft 下载 EntityFramework,有关此程序包的许可协议在http://go.microsoft.com/fwlink/?LinkID=320539上提供。请检查此程序包是否有其他依赖项,这些依赖项可能带有各自的许可协议。您若使用程序包及依赖项,即构成您接受其许可协议。如果您不接受这些许可协议,请从您的设备中删除相关组件。

Install failed. Rolling back…
install-package : 将“EntityFramework 5.0.0”更新到“EntityFramework
6.1.3”失败。找不到与“EntityFramework 6.1.3”兼容的“EntityFramework.zh-Hans”版本。 所在位置 行:1 字符: 1

错误原因:关联的这个包版本太低,与其相关的要升到高级版本,这个包却不支持。

解决方法:
【1】在NuGet 查找EntityFramework.zh-Hans 更新到最新版本
【2】删除程序集文件夹packages里的EntityFramework…..(版本号),然后重新安装装

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:4547次
    • 积分:69
    • 等级:
    • 排名:千里之外
    • 原创:2篇
    • 转载:3篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档