(数位DP 1.2)hdu 3555 Bomb(统计1~n中,包含49的数的个数)

题目:

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 9273    Accepted Submission(s): 3275


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3554  3556  3557  3558  3559 


题目分析:

                数位DP。


这些是状态转移方程

dp[i][0]=dp[i-1][0]*10-dp[i-1][1];                         //代表不含49 (当位数增加一位,不含49的数增加10倍,但是要减去一个以9开头的)
dp[i][1]=dp[i-1][0];                                             //代表不含49,但以9开头(当位数增加一位,就增长了在原来不以9开头的那些)
dp[i][2]=dp[i-1][2]*10+dp[i-1][1];                       //代表包含49(当位数增加一位,之前已经包含49的增加10倍,另外要加上现在开头为4和之前开头为9组合成49的数)



DP的状态是2维的dp[len][3]
dp[len][0] 代表长度为len不含49的方案数
dp[len][1] 代表长度为len不含49但是以9开头的数字的方案数
dp[len][2] 代表长度为len含有49的方案数

状态转移如下
dp[i][0] = dp[i-1][0] * 10 - dp[i-1][1];  // not include 49  如果不含49且,在前面可以填上0-9 但是要减去dp[i-1][1] 因为4会和9构成49
dp[i][1] = dp[i-1][0];  // not include 49 but starts with 9  这个直接在不含49的数上填个9就行了
dp[i][2] = dp[i-1][2] * 10 + dp[i-1][1]; // include 49  已经含有49的数可以填0-9,或者9开头的填4

接着就是从高位开始统计

在统计到某一位的时候,加上 dp[i-1][2] * digit[i] 是显然对的,因为这一位可以填 0 - (digit[i]-1)
若这一位之前挨着49,那么加上 dp[i-1][0] * digit[i] 也是显然对的。
若这一位之前没有挨着49,但是digit[i]比4大,那么当这一位填4的时候,就得加上dp[i-1][1]


代码如下:

/*
 * hdu355_1.cpp
 *
 *  Created on: 2015年4月13日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn = 25;
typedef long long ll;
ll dp[maxn][3];//这道题的方案数比较大,所以这里要使用long long


/**
 * 初始化,计算他们之间的关系
 */
void init(){
	memset(dp,0,sizeof(dp));
	dp[0][0] = 1;

	int i;
	for(i = 1 ; i < maxn ; ++i){
		dp[i][0] = dp[i-1][0]*10 - dp[i-1][1];
		dp[i][1] = dp[i-1][0];
		dp[i][2] = dp[i-1][2]*10 + dp[i-1][1];
	}
}


ll solve(ll n){
	ll ans = 0;

	int digit[maxn];
	int len = 0;
	while(n > 0){
		digit[++len] = n%10;
		n /= 10;
	}
	digit[len+1] = 0;

	int i;
	bool flag = false;
	int last = 0;
	for(i = len ; i > 0 ; --i){//遍历每一个数位
		ans += dp[i-1][2]*digit[i];
		if(flag == true){
			ans += dp[i-1][0]*digit[i];//如果其高位存在49,则低位不管是什么数都存在
		}
		if(flag == false && digit[i] > 4){//位置,且首位大于等于5,至少存在低一位有9的情况的个数
			ans += dp[i-1][1];
		}

		if(last == 4 && digit[i] == 9){
			flag = true;
		}
		last = digit[i];
	}
	return ans;
}

int main(){
	int t;
	scanf("%d",&t);

	init();
	while(t--){
		ll n;
		scanf("%I64d",&n);
		n++;

		printf("%I64d\n",solve(n));
	}

	return 0;
}







  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值