HDU--杭电--4004--The Frog's Games--二分

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 3000    Accepted Submission(s): 1484


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
  
4 11
 
题意:蛤蟆直线过河,直线上有石头可以踩,告诉你河的宽度还有石头个数还有最多可以跳几次,每种过河方案都有一个单次跳的最大距离,让你求出所有方案里面单次跳的距离最小的那个方案,并输出这个距离
从单次跳的最大距离下手进行二分,而过河最少跳一次,所以单次跳的最大距离应该就是河的跨度



#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int n,m,d[555555];
int cc(int mid)	//选择一个单次跳的最大距离
{
    int i,j,k,l;
    for(i=1,k=l=0;i<n+2;i++)	//模拟过河走一遍
    {
        l+=d[i]-d[i-1];	//积累距离
        if(l>mid)l=d[i]-d[i-1],k++;	//到正好凑够当前跳的最大距离时,跳的次数加一,同时初始化积累的距离
    }
    return l>mid?1<<30:k+1;
}
int main (void)
{
    int l,i,j,k,mid,x,s;
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        for(i=1;i<=n;i++)
        scanf("%d",d+i);
        d[n+1]=l;	//终点岸
        d[0]=0;	//初始岸
        sort(d+1,d+n+1);	//把点排序
        for(i=1,j=0;i<n+2;i++)
        j=max(j,d[i]-d[i-1]);	//得出点的最小间距
        i=j;j=l;
        while(i<j)	//进行二分
        {
            mid=(i+j)/2;
            if(cc(mid)<=m)j=mid;	//因为mid是中点,而且是靠近左边点的,所以右界要跳到mid而不是他前一个,因为mid可能就是对的那个
            else i=mid+1;
        }
        printf("%d\n",i);
    }
    return 0;
}

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值