poj 1463 Strategic game (树形DP)


Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree: 

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or 
    node_identifier:(0) 

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2
 
<span style="color:#ff6666;">题意:给出一棵树,要求找到最少放几个士兵才能将所有点都看守到,每个节点的士兵只能看守临近一个的节点</span>

思路:标准的树形DP,建树的时候要双向都建

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
   int now,next;
}str[3005];
int dp[1505][2],vis[1505],head[1505];
int root,len;
void add(int x,int y)
{
    str[len].now=y;
    str[len].next=head[x];
    head[x]=len++;
    str[len].now=x;
    str[len].next=head[y];
    head[y]=len++;
}
void dfs(int rt)
{
    vis[rt]=1;
    dp[rt][1]=1;
    dp[rt][0]=0;
    for(int i=head[rt];i!=-1;i=str[i].next)
    {
        int k=str[i].now;
        if(!vis[k])
        {
            dfs(k);
            dp[rt][0]+=dp[k][1];
            dp[rt][1]+=min(dp[k][1],dp[k][0]);
        }
    }
}
int main()
{
    int t;
    while(~scanf("%d",&t))
    {
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        root=-1;
        len=0;
        for(int i=1;i<=t;i++)
        {
            int x,n;
            scanf("%d:(%d)",&x,&n);
            if(root==-1)
               root=x;
            for(int j=1;j<=n;j++)
            {
                int y;
                scanf("%d",&y);
                add(x,y);
            }
        }
        dfs(root);
        printf("%d\n",min(dp[root][0],dp[root][1]));
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值